K40 Laser cutter wont fire on jobs. Still fires on panel/psu test.. Gives Message "L" - No Laser Signal

Hey Don,

I have received and replaced the Waterflow Sensor. Its been rewired and the chiller now sees a temp again. Next, I received and rewired a strand of wires that go to the controller board that control X and Y… Every wire literally fell out of the cable connection from all the testing… Thursday I have a new cable end coming to rewire the L signal wire. The female “L” signal wire is worn out and wants to pull out of the cable end and the other wires in this cable end are bent from all the testing… I am totally with you on getting this dude up and running… Give me a few more days to have a this connection fixed and see if the new cable or the new water flow sensor has resolved anything. I have a new power supply on order from aliexpress. I requested 5 day shipping but its looking delayed and I cant get one here any faster. Again the power supply may not be the issue. But give me a couple days here to give you accurate results with new cabling and a new water flow sensor.

I have added the last thing I was able to laser as it slowly died (Before I reached out to you). Ignore the top left corner. I was test firing (As test firing still works on test panel and LSU test button)… But you will notice the laser lost more and more power until it stopped cutting all together.

Again, adding some picture of the cable ends that are falling apart. New wiring is the new connection replaced, chiller now reads temps again after waterflow sensor, new waterflow sensor installed, and pic of last thing I was cutting when it died.

Talk to you Thursday night once the new “L” cable is installed and I can fully test again.



I have installed a lot of new parts and the machine STILL displays the dreaded “No laser signal” and the machine still continues to not fire when cutting. Again it still will fire when pushing the test button on the panel and test button on the LSU power suppy.

I have replaced the following.

2 new wire strands that got to the controller board. The “LO 5v GND 24v”. As well as a wire strand that controlled the x & y cable that had been coming loose.
Replaced the Waterflow sensor.
Replaced the Power Supply.
Replaced the controller board
Replaced the USB cable to the laptop
Its a new laser bulb that had been used about 4 times before it started doing this (I still have the old one that was getting really weak) The bulb fires on test with no problem… Should I put my old bulb back in it to see if that’s the issue?

I uninstalled and reinstalled k40 Whisperer (No change) Don’t think its the software.

The new Digital Cloudray Power supply digitally shows No Laser Signal as did the original generic one. Sadly its not the power supply as you had predicted but I was down to try anything to get past this.

You had asked what happens if I tried to engrave instead of cut. You had instructed me to hold the test button down as it moved around. Well it engraved… It also drags the firing laser everywhere… It doesnt shut off when it crosses words… But it will engrave and it will cut with no issue on either test button.

So… what are your thoughts with the components replaced. Is it possibly a wire, do you want me to check voltage. Or maybe its a switch that went bad. I have have a switch that is on the front of the laser that says laser signal. If i turn it, it says Water flow protection off, turn it back and it says water flow protection on. But the laser signal never changes. Is it possible there is a fuse on these I could check to see if may have blown? Let me know your thoughts. Again I appreciate all your thoughts.

I am sorry that all these replacements did not fix your problem I know this is frustrating. :frowning: :frowning:

I need to digest this post and history and I will come back by tomorrow with some suggestions.

Here are my visceral thoughts…

Since it cuts and engraves properly (except the lines between moves) with the test button pushed these subsystems must be working. Otherwise, you would not get these results.

  • Software
  • Power supply
  • USB cable
  • Controller board
  • Laser tube
  • X-Y components and

I am surprised that it engraves with the test button. The good news is that this means that your controller and most everything else is working.

Working theory:
Something is not enabling the LPS when a job is run. When the test button is held down it is substituting for that enable.

I will think up some test measurements and get back with you ASAP.

1 Like

Please use reference # in your response

As a stab in the dark run this test first.

  • At the LPS-L there should be two wires connected, remove the wire that comes from the digital panel (i.e. test switch). Leave it open but tape it off so that it does not short to anything.
  • Leave the connection from the controller to the LPS-L pin wired (connected). At this point LPS-L should have only one wire connected.
  • Run an engraving job, do not push the test button, see if the job runs normally


  1. Does the job run normally?


Setup questions:

  1. Does the Rev1.1 schematic (post above) still reflect how the machine is now wired?
  2. The test switch connection to the LPS-L comes from the digital panel correct?
  3. What pin on the digital panel does the wire connected to LPS-L come from? Please provide a picture of that connection.

Voltage tests on LPS connector:
With these conditions:

  • Machine: ON
  • Laser Switch: ON
  • Water flowing
  • DVM: - (black) lead connected to LPS-G
  • DVM : DC volts scale
  • LPS-L: reconnected to the digital panel

Measuring the voltage on the LPS connector
*for each of the below measurement take a picture of the DVM display and panel

With the DVM +(red) lead on each of the below LPS pins, measure the voltage

  1. H pin:
  2. L pin:
  3. P pin:
  4. G pin:

Make the same measurements, under the same conditions, again EXCEPT this time with the TEST button held pressed while the measurements are being made.

  1. H pin:
  2. L pin:
  3. P pin:
  4. G pin:

This is what the results would look like in a table

LPS pin test button NOT pushed test button pushed
H __V __V
L __V __V
P __V __V
G __V __V

Will do Don and I will report back with your testing suggestions.

I reverted back to my old laser tube moments ago to verify its not the bulb. It did the exact same thing. Won’t fire when running a job. But does fire on both test buttons. I put the new bulb back on as it’s not the problem and more powerful.

I will work on the testing and reply shortly.



Don, Happy Easter!!! And the laser cutter is now fixed. It was a grounding issue. I would love to take credit for solving it, but my buddy Scorch_works and I worked through your tests and he determined it wasn’t properly grounding.

The issue: Grounding (How did I test for this.)
Using the voltage meter Red Positive Tester (+) to LSU GRND. (-) to Metal Laser Housing Result = .00
Using the voltage meter testing (+) to DC Power Supply GRND. (-) to Metal Laser Housing Result = .95

The (LSU) Laser Power supply was not getting a good ground and gave a read out of .00. I powered off the laser, unplugged it. Then connected a scrap wire from LSU Grnd to DC Power Supply Grnd. Plugged it in, powered it on. The laser now Cuts, Engraves with zero issues, just like brand new. 100% functional again. All jobs fire the laser correctly now.

Things to note… for people in the future having the same issue and reading this. I did use a dremel to grind off all the paint on the inside Metal Laser Housing Grnd terminal (screw) which is located in the back of the Laser cutter. I also made sure the ground wire had a solid metal connection to that bare metal. With that said… I had read laser cutters having grounding issues on past forums thus why I tried this. But you may run into what I did and find a Power supply not getting a good ground. Which is kinda crazy because the 220v outlet has a 3 prong with ground so you would have thought it gets a ground there. Again if your having it test fire perfectly but wont fire on jobs. Test the Grnd on both power supplys to the metal housing case and you should get a read out of .95. If not, you dont have a ground to that power supply.

Don… Being its solved… There is little point in rattling off voltages of all the pins. But you may stumble over them in the future and this may be helpful for someone else. These are the readings before the system was properly grounded and fixed.

Voltage meter on “L” wire to Grd while cutting - 4.0 then 4.03 then 4.0

Voltage meter on “L” wire to Grd while engraving - 4.04 then 4.02 then 4.0

Voltage meter on “L” wire to Grd while (NO TEST NO CUTTING - IDLE) - 4.0 exactly

Voltage meter (+) on LPS “G” the (-) on DC Power Supply Grnd - .95

Unplugged Black “L” Wire (Separated the white wire that goes to the Panel)

Voltage meter (+) on LPS Black Wire unplugged from “L” that came from (LO) to (-) LSU GRND = 2.44

Voltage meter (+) on LPS Black Wire unplugged from “L” that came from (LO) to (-) DC Power Supply GRND = 4.84

Voltage meter (+) on LPS Black Wire only that goes to “L” from (LO) to (-) DC Power Supply GRND = 4.92 then .03 then it would move the laser head and 4.92 and then act like its cutting and go back to .03

It was determined that the Controller board was correctly working at this point.

Then it was determined it was a Grnd issue at this point: (Note I had to scratch off the paint to do this test. You have to hit bare metal on your laser case to ground)

Voltage meter on LSU GRND to Bare Metal laser housing while running a cutting job = .00
Voltage meter on DC POWER SUPPLY GRND to Bare Metal laser housing while running a cutting job = .95

At that point it was determined both grounds were not equal and both be .95 and LSU was not grounding. So a wire was connected from LSU Grnd to DC power supply Grnd. Then everything worked.

Don, I want to thank you for you weeks of work and patience. Man I greatly appreciate it and would like to donate money to your beer fund. Just let me know how I can do that. Paypal, Patreon, Raking Leaves, washing cars… :slight_smile: I attend a lot of wood working conventions and get together’s and would like to shake your hand one day… or maybe foot bump since we cant do that any more. lol Be safe and thank you. I hope you have a wonderful easter and I hope this was a good egg to find. And straight up thanks to Scorch_Works… That dude helps a lot of people on here as well. Thank you both for helping get my company get back on its feet and i am for sure indebted to you both. Thanks -Brian


Picture of spare wire I added to fix my machine from DC Power Supply GRND to LSU GRND.


Thanks @Scorch!

FWIW, That’s one of the recommendations in this introductory article by @keen — scroll down to the diagram showing how he re-worked his ground:

Lots of gold in those articles.


…to be clear this problem was solved by adding a wire between the DC supply and the LPS grounds. This is not a safety ground issue but a logic power grounding one.

This means that the LPS and controller power were not both at the same ground reference making the L signal have a “wonky” [technical term?] ground reference. Likely the “test” button was indirectly providing a better reference when pushed.

@WoodenCreationz just for grounding hygiene I would ensure that your controllers ground is connected directly to the DC supplies ground.

@WoodenCreationz you can find a “Donate” button on my blog about 1/2 down on the right side…


@donkjr here is a little background information.

I told @WoodenCreationz about this forum when I heard about his laser problem. I knew this is were he would get the best help (I didn’t know how to help him at the time). After reviewing the information the two of you compiled in this thread I decided to reach out to Brian to see if we could bring it to conclusion last night.

@donkjr this issue would not have been resolved without the schematics and other information you put together earlier in this thread. Thanks for your high quality and diligent work!



@Scorch thanks, it was a team effort!
I’m just glad Brian is back up and running!!!


Hi guys. I appreciate all the time and effort put into this very informative thread, and thus the knowledge created to provide solutions. I’ve been stuck for over a month with the exact same problem with my first K40 and have followed this thread step by step with my multimeter.

Upon my consideration of trying the official solution, I noticed that my K40 doesn’t appear to have a DC supply.

This could be as my K40 is a version with a nob to alter the power rather than buttons and digital display like in this case - would this potentially mean a different solution, or is it still likely to be the LPS and controller power at different ground references?

I’ve attached images of the wiring/ hardware components, and the exterior controls. (Just 1 image now as I’m a new user).

Any comment/ word of advice would be much appreciated (novice when it comes to electronics).


Exactly what is your problem?

That supply should have a 12v and 24v DC output.

Thanks for the quick response.

My laser doesn’t fire when I send a file to the K40, the laser head goes through the motions as if it were cutting & engraving but without the laser firing. The laser fires when I press the test button & power increases / decreases responding to the nob.

I’ve checked all the wires for continuity and they’re fine, as well as resistance.

Okay I assume the supply does have 12v & 24v DC output.

Thanks for the diagram, that makes things easier to understand

Does the laser fire under any circumstances?

Does the laser fire if you push the red test button down on the LPS?

Yes, the laser fires when I press the test button.

It also fires when I press the LPS test button

Ok your LPS seems ok, the problem is likely elsewhere.

I assume you have the “Laser Switch” enabled/On when you run the job?

Does your machine have interlocks, water flow sensor etc?

Please post a picture of your control panel.

Yes, the Laser Switch enable is on when I run a job.

It doesn’t have interlocks nor a water sensor.

What controller is in the machine?

Try this;
Power off

  • Disconnect what is on L (the rightmost connector). Should be coming from the controller.
  • Connect a jumper to L that you can touch (short) to ground

Put Laser glasses on

Power ON

  • Laser Switch to ON
  • Touch the jumper on L to ground.

Here’s a picture of the controller:

  • By jumper to you mean a jump wire? Meaning I’ll need a spare?

I’ll try this tomorrow morning as it’s late in the UK and will post the result