So I finally found some time to work on my Rostock Mini,

3d-faq
3d-qa
3d-help
gplus
(Aaron Leclair) #1

So I finally found some time to work on my Rostock Mini, but of course I’ve run into a problem with firmware, or maybe it’s a hardware problem.

The endstops y and z show up as hit whenever I try to test out the printers movement. I’ve tried every software and hardware configuration and still the endstops show up as hit in the Repetier terminal. I’m using a Rumba board that I got from RepRapDiscount’s IndieGoGo campaign and Marlin firmware for Delta printers.
Please help!

(Richard Turnock) #2

Not sure if I can help or hinder…
Use M119 to report the status of the endstops.
First, move the hot end down, away from the endstops.
check M119, the message should be “open”
use your hand or have someone help you, push on one the endstops to trigger it, check M119.
If all your endstops do not report the correct status, then you have a wiring problem. An open circuit or a short.

(Thomas Sanladerer) #3

Do they show up as open when you manually trigger them? Is the right board selected in your firmware?
Also, here’s a guide i made on all things firmware: https://www.youtube.com/watch?v=2RbcMvhatjU&list=PLDJMid0lOOYnRCAdbFfzECor3EbqF8euw&hd=1 (starting at 13:22, i give a little advice on endstop debugging)

(Aaron Leclair) #4

Fixed! I don’t know what the problem was but it turned out that the logic for the x endstop was opposite of the y and z endstops, even though they’re identical switches and all wired the same.

I switched the logic levels accordingly, and they work now.

Another problem has shown up now, when I home the endstops the carriages repeatedly bash themselves into the endstops at a really high speed. I remember reading that with mechanical endstops that the pull up resistors had to be changed in the firmware. Is that true? I checked your video @Thomas_Sanladerer , but you skipped over that section of marlin.

(Thomas Sanladerer) #5

@Aaron_Leclair by default, the pullups are enabled, which works for most configurations. If your endstop is more than a simple switch and has its own pullup resistor, you might need to disable it there.
If M114 reports open/closed correctly, then you might still have an axis’ motor and the homing direction inverted. If it’s only the speed that’s too high, you can reduce it in configuration.h, but the defaults are already pretty conservative.

(Aaron Leclair) #6

I’ve slowed down the travel speed, and its made the problem more obvious. It appears as though the endstops aren’t registering, but when I check with m119 they show their current state. My best guess would be that the problem is firmware related, but maybe it’s electrical? I’m going to try a different power supply, as I noticed the current one behaving erratically while powering the rumba board.

(ThantiK) #7

Aaron, your end stops need to be wired to the correct towers. If they aren’t, they’ll hit the wrong ends top and ‘not register’

(Aaron Leclair) #8

Anthony, I’ve double and triple checked them, they are all wired properly.