Meerkat use with diode engraver

EDIT/UPDATE: Got meerk40t running native in Linux with a sculpfun S9 pro (and s30 ultra) diode-based engraver.

I’m curious if anyone has used meerkat with any of the diode laser engravers that are on the market these days. I’m looking around for a diode machine to try out and would prefer if I could use software that is well known (and FOSS) amongst this group. Any input would be valuable. Thanks in advance!

They more or less all use GRBL, and…

Supported devices

  • M2-Nano
  • Moshiboard
  • GRBL
  • Fibre Lasers based on the JCZ controllers (still experimental)
  • Ruida-Emulation (Middleman between Lightburn and K40)

Fair enough. I’ll grab one and give it a try. May post about my experience.

Decided on the xtool D1 Pro and I’m getting nowhere fast (using with MeerK40t 0.8.10). I’ve gotten as far as getting the machine to connect to the software via USB, but nothing is physically moving on the machine. Can’t jog the head and sending an actual job seems to go through on the computer’s end, but nothing is physically happening on the machine. Logistically speaking, it has the same ch340 chip as the sparkfun 9S has (which I have sitting in another location at this moment, so I can’t try it out, but I was able to get LaserGRBL to work on that one, so hopes are high here, even though LaserGRBL has not yet worked on the xtool. Not even sure what logfiles I can grab to send in to help troubleshoot. It’s been interesting spending the day trying to get this figured out. Oh, and to be clear, the machine turns on, no beeping or other indicators that anything is improperly connected or built. So I’m at a loss for what could be going on. I don’t really have a windows computer to throw at this thing to see if it will respond differently at the moment…

Just and FYI, the USB chipset is just what provides the serial communications, what is ‘behind’ the serial port is what’s important for whether software X will understand the protocol or not. Your diode laser firmware(the stuff behind the USB communications connection) is probably the GRBL firmware.
So if you read the MeerK40t website regarding which board or firmware it supports, if you see GRBL then it should work. If you don’t see GRBL then it’s likely not going to understand what’s going over the USB communications wire and won’t work.

Figuring out what I did right, but I was able to get MeerK40t 0.8 to jog a sculpfun S9.

2 Likes has to be ran with sudo and the machine becomes responsive. Going to play around with this now and see if I can figure some things out. I’ll come back to the Xtool when I have time.

1 Like

Usually that means just needing to add yourself to a group that has permissions for the device. :crossed_fingers:

Valid point. I’m not sure which group I’d need permissions for at the moment (my guess is that it’s related to how it functions with the USB port). But I can confirm that it at least “works” in native linux. I have been able to take a file in inkscape, save it, open it in meerk40t and engrave the image (or at least start to engrave… I’ve still gotta figure out alignment stuff in general so I can place materials properly and such). My only issue at the moment is that it’s not respecting the gradient of the object I made in inkscape (comes up as a solid black object in meerk40t and haven’t figured out how to fix that just yet).

Add your user to the dialout group, this is the standard for the /dev/ttyUSB* devices in Linux.

1 Like

My current version of linux doesn’t have dialout. Did some research and found that the replacement for that is uccp. Added myself to that and it made no change. So, for now, my workaround is a gksu-based script in /usr/bin to run the program. Currently engraving on 0.9.1 stable as of 5 minutes ago.

No, it isn’t. Uucp is a user account+group used to configure some stuff, and nothing to do with this. Also GKSU has been depreciated for a long time. Even Debian dropped it years ago.

It’s difficult trying to help people who don’t specify basics like the actual linux version they are running etc.

1 Like

And maybe what distro and version of Linux you are using would be helpful? Are we talking Yggdrasil from 2000 or what.

The output of the command ls -l /dev/ttyUSB* with the engraver connected and powered on might be helpful here.

1 Like

Not quite remembering where I stumbled on that suggestion, but when I figured out that dialout doesn’t exist on the version of linux I use, that was the suggestion on the forum that I found. I’m running Manjaro Linux, btw. And gksu has been the only app of its kind that has worked for me with consistency. So Ive stuck with it. :man_shrugging:t6:

Manjaro Linux. My original install is like 3 years old, but I’m mostly up to date with the rolling releases of apps… maybe 6 weeks behind whatever is current. I can give version numbers to whatever app you ask me about to see if I’m running what I should be. I just know I’m slightly behind the most recent large update.

Tends to be /dev/ttyUSB0 or USB1

The reason I gave the exact command was that if you run the exact command it’s not just the name of the file, and the reason for it wasn’t to get the name of the file, it was to get the rest of the information in the long listing, particularly the name of the group and the permissions on the file.

crw-rw---- 1 root uucp 188, 1 Sep 27 19:58 /dev/ttyUSB1

OK, yeah, then it’s the uucp group for you! (UUCP was Unix-to-Unix CoPy, a predecessor to the current internet that was based mostly on intermittent connections, often using modems, and the name persisted long past the technology’s normal lifetime. The dialout name is much newer.)

You’ll need to find out how to add yourself to the uucp group on your Manjaro system. It may be sudo usermod -G -a uucp $LOGNAME but sadly there are couple different implementations of that command because it was not a standard at the time the different implementations were created. After you run that command, you will have to log out of the system and log back in again, and then you should be in the group. You can test that with the id command which should list the uucp group in your groups list.

1 Like