I'm implementing auto bed level function to my old printer.

3d-faq
3d-qa
3d-help
gplus
(DongWon Han (DWONH)) #1

I’m implementing auto bed level function to my old printer.
But I’m stuck in setting z probe offset.

I’ve done every procedure of the @Thomas_Sanladerer 's video, but I got more than 1mm gap from the bed after I finished setting. That gap is not proper value, I think, can be adjusted by slicer’s z-offset option.

Here are the log from G29 leveling procedure.

12:45:16.301 : Bed x: 10.00 y: 30.00 z: 0.37
12:45:21.681 : Bed x: 140.00 y: 30.00 z: 0.96
12:45:26.821 : Bed x: 140.00 y: 120.00 z: 0.88
12:45:32.539 : Bed x: 10.00 y: 120.00 z: 0.11
12:45:32.545 : Eqn coefficients: a: 0.01 b: -0.00 d: 0.32
12:45:32.547 : planeNormal x: -0.01 y: 0.00 z: 1.00
12:45:32.549 : echo:endstops hit: Z:0.11

And
Z_PROBE_OFFSET_FROM_EXTRUDER -0.7

I don’t think the result what I’ve got is normal.
What am I missing.

And one more question,
What’s the ‘z value’ means from G29 or G30 probe?
I want make things more clear.

Thanks.

(Peter Hertel) #2

Are you using marlin? Last time I tried bed tramming was simply broken, but it was a few months ago. Check out the discussion on github for the latest info on that.

(DongWon Han (DWONH)) #3

@Peter_Hertel Yes, 1.0.2 release version.
Could you point me the link? I thought many people already using auto-leveling with Marlin. Am I correct?

(Peter Hertel) #4

Some info here https://github.com/MarlinFirmware/Marlin/issues/2293 seems like it could be fixed in the Dev branch instead of stable.

(DongWon Han (DWONH)) #5

@Peter_Hertel I don’t think that issue relevant with mine.
The problem I have is that I can adjust z-offset no matter how I change Z_PROBE_OFFSET_FROM_EXTRUDER value in firmware(at least, it seems like that). It has always about 1mm gap between nozzle and bed.

(DongWon Han (DWONH)) #6

Situation goes more strangely, suddenly, G28 command does not make probe move to center without any code change. Z homing at the X,Y home position, instead.
It makes me really frustrated. :frowning:

(Peter Hertel) #7

You shouldn’t use g28 after g29 as it removes all measured data points.

(Chris Lau) #8

I had a similar issue but the Z offset wasn’t going through, no matter what value I put into it. I tried using Slic3r’s z offset feature but that didn’t work either. The only solution that I could find that works is by defining the Z offset by writing it in the START GCODE. Set your Z offset to 0 and use the following gcode commands:

G29 (auto calibrate head)
G1 Z-0.25 (move Z down, your offset value)
G92 Z0 (define as new Z home)

(Keith Applegarth) #9

Remember to reverse the signs on the values you get. I would probably go back and re-accmoplish the proceedure again.

(DongWon Han (DWONH)) #10

@Peter_Hertel Yes, I know but I can not do ‘safe homing’ by G28 now. I have to solve the reason first hopefully.

(DongWon Han (DWONH)) #11

@Chris_Lau Thanks for the tip!, but I’ll try it for last method. I’m curious how other people doing in adjusting z offset.

(DongWon Han (DWONH)) #12

@Keith_Applegarth Thanks for comment, Could you give me a simple procedure if you already did successfully?

(Camerin hahn) #13

Are you doing g28 with arguments?
G28 X0 Y0
This is the printrbot first steps page for auto leveling… It is pretty good.
http://help.printrbot.com/Guide/Setting+Up+Your+Auto-Leveling+Probe+and+Your+First+Print+-+Mac/107

(Keith Applegarth) #14

@DongWon_Han_DWONH Are you using an inductive sensor or a servo?

(DongWon Han (DWONH)) #15

@Keith_Applegarth I am using same inductive sensor that is used by Printrbot.

(DongWon Han (DWONH)) #16

@Camerin_hahn No, just G28. It has worked just some hours ago. (Hotend moves to center) I have no idea what caused change. One thing I found is MAX Z endstop is somehow triggered always after some point. Which was not like that. I confirmed configuration again but status would not change. I think it might be the reason coz I saw mis-configured endstops cause unexpected movement of G28 before.

(DongWon Han (DWONH)) #17

judging by strange status of MAX-Z endstop, I guess PIN of my RAMPS broken. I have to find out way to resume test

(Keith Applegarth) #18

@DongWon_Han_DWONH Unfortunately, I am using a servo, so it is a bit different. But for the Z offset, mark a spot on your bed. Bring the nozzle down to that spot to the correct printing height. Zero out your Z axis. I usually just disconnect/reconnect Repetier. That zeros out everything. I raise my probe 20mm (you can probably get away with 10mm). Center the probe over the marked spot and start lowering the probe till it triggers. The number it triggers at is the Z offset.

I usually do it in about 3 spots to double check myself.

I hope that helps. Tom’s video is pretty thorough. I used ZennmasterM’s videos for mine. You can find those here:

(DongWon Han (DWONH)) #19

@Keith_Applegarth Thanks!! I’ll try as soon as I fix another issues.