Griffin Paquette   Ishaan Gov   Giuseppe Caldara   Matthias Lewen     and

3d-faq
3d-qa
3d-help
gplus
(James Malenko) #1

@Griffin_Paquette1 @Ishaan_Gov @Giuseppe_Caldara @Matthias_Lewen-Riege and anyone else that can help.

I’m using the inductive sensor and I changed the firmware to normally closed, but now this happens when I auto home all axis, after the x and y home.

cb0b04882219dbcd0d69350eac6718b2.gif

(Peter Hertel) #2

You shouldn’t run g28 after a g29.

(James Malenko) #3

What’s g28 and 29?
I don’t know most of the commands, I usually use the gui to control it.

(Peter Hertel) #4

G29 runs the auto bed tramming routine, and if you do a G28 homing it resets the data it collects.

(James Malenko) #5

Oh. Ok I’ll try running only g29 from a computer then. Will that work?

(Peter Hertel) #6

If your firmware is configured correctly, yes. :slight_smile: You need to enable auto bed levelling/tramming, configure probe points and position and reupload firmware.
Perhaps I read your post wrong, is this a new build or are you adding tramming to it? If it’s a kit, the firmware should be set up for you already.

(James Malenko) #7

It’s my own build, I enabled auto levelling.

// Uncomment the following line to enable CoreXY kinematics
#define COREXY

// coarse Endstop Settings
#define ENDSTOPPULLUPS // Comment this out (using // at the start of the line) to disable the endstop pullup resistors

#ifndef ENDSTOPPULLUPS
// fine endstop settings: Individual pullups. will be ignored if ENDSTOPPULLUPS is defined
// #define ENDSTOPPULLUP_XMAX
// #define ENDSTOPPULLUP_YMAX
// #define ENDSTOPPULLUP_ZMAX
// #define ENDSTOPPULLUP_XMIN
// #define ENDSTOPPULLUP_YMIN
// #define ENDSTOPPULLUP_ZMIN
#endif

#ifdef ENDSTOPPULLUPS
#define ENDSTOPPULLUP_XMAX
#define ENDSTOPPULLUP_YMAX
#define ENDSTOPPULLUP_ZMAX
#define ENDSTOPPULLUP_XMIN
#define ENDSTOPPULLUP_YMIN
#define ENDSTOPPULLUP_ZMIN
#endif

// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
const bool X_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool X_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
//#define DISABLE_MAX_ENDSTOPS
//#define DISABLE_MIN_ENDSTOPS

// Disable max endstops for compatibility with endstop checking routine
#if defined(COREXY) && !defined(DISABLE_MAX_ENDSTOPS)
#define DISABLE_MAX_ENDSTOPS
#endif

// For Inverting Stepper Enable Pins (Active Low) use 0, Non Inverting (Active High) use 1
#define X_ENABLE_ON 0
#define Y_ENABLE_ON 0
#define Z_ENABLE_ON 0
#define E_ENABLE_ON 0 // For all extruders

// Disables axis when it’s not being used.
#define DISABLE_X false
#define DISABLE_Y false
#define DISABLE_Z false
#define DISABLE_E false // For all extruders
#define DISABLE_INACTIVE_EXTRUDER true //disable only inactive extruders and keep active extruder enabled

#define INVERT_X_DIR true // for Mendel set to false, for Orca set to true
#define INVERT_Y_DIR true // for Mendel set to true, for Orca set to false
#define INVERT_Z_DIR false // for Mendel set to false, for Orca set to true
#define INVERT_E0_DIR true // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E1_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E2_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false

// ENDSTOP SETTINGS:
// Sets direction of endstops when homing; 1=MAX, -1=MIN
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1

#define min_software_endstops false // If true, axis won’t move to coordinates less than HOME_POS.
#define max_software_endstops false // If true, axis won’t move to coordinates greater than the defined lengths below.

// Travel limits after homing
#define X_MAX_POS 213
#define X_MIN_POS 0
#define Y_MAX_POS 200
#define Y_MIN_POS 0
#define Z_MAX_POS 300
#define Z_MIN_POS 0

#define X_MAX_LENGTH (X_MAX_POS - X_MIN_POS)
#define Y_MAX_LENGTH (Y_MAX_POS - Y_MIN_POS)
#define Z_MAX_LENGTH (Z_MAX_POS - Z_MIN_POS)
//============================= Bed Auto Leveling ===========================

#define ENABLE_AUTO_BED_LEVELING // Delete the comment to enable (remove // at the start of the line)
#define Z_PROBE_REPEATABILITY_TEST // If not commented out, Z-Probe Repeatability test will be included if Auto Bed Leveling is Enabled.

#ifdef ENABLE_AUTO_BED_LEVELING


-Mihir Melwani
14melwanimn1@webmail.sis.edu.hk
9S2

(Anatoly Magerovsky) #8

Cool

(Giuseppe Caldara) #9

You can lauch gcode in Repetier Host

(Griffin Paquette) #10

I use pronterface but Repetier will work as well. Connect the printer and type G28. Once it runs that command type G29 and it should run autoleveling. If I didn’t put G28 before my G29 command it wouldn’t work right and looked kinda like what you have.

(Ishaan Gov) #11

Also try homing the X & Y axes in one go then the Z axis (G28 X0 Y0 then G28 Z0); I’ve had some weird unexplainable issues with a straight G28 command, then you can try your G29