Computer/Libusb/Whisper does not see Laser

Hello everyone!

So I unplugged my laser to move it to its forever home in my office and now when I tried to use it Whisper said that the LIBusb driver was not installed. No worries got the K40 Driver install from @Scorch 's website. However it also says that it does not see any devices. Ok… lets try and uninstall and do a fresh install, back to @Scorch 's website to follow the how to, but the driver I should see in device manager is not listed, so no uninstall. Anyone got any ideas? I looked around on the internet and here, the only thing I found on here close to this, the person had to replace the board. While that is in the plan, I was hoping to get a little use out of the current board. Thanks in advance for your help.

Side note, I have power cycles everything… and yes the laser is plugged up to power and turned on. lol

When you turn tha laser on does the laser head go to the home position? To check you can move the laser head to the middle of the cutting area, then turn the laser on. it should move to the home position. If not the controller might not be getting power (or less likely, the controller could be broken)

Also make sure USB connections are all fully plugged in. You could also try a different USB cable to make sure there is not a broken wire in yours after the move.

@Scorch thanks for getting back to me, I moved the laser head from the home spot and turned on the laser, it moved back to the home spot. The cable to connected and seated, the cable it self is brand new. However I have another one still in the box, so I tried that one. It still is not being seen.

Sorry, I don’t know why it would suddenly stop seeing the laser.

Does anyone have any tricks on how to “test” the control board and see if it is working or not?

Try a different USB port. Try a different USB cable.

To eliminate potential ground loop issues, plug the PC/laptop into the same outlet or run the laptop off its battery. (USB is a bit crap.)

Visually inspect the USB socket on the controller. It’s somewhat easy to damage it when the cable is plugged in.

Try listing the USB devices via PowerShell:

1 Like

Still nothing, I have sent an email to the seller. Everything I can find on the internet points to the board having gone out. We shall see what they say.

You moved both the laser and the laptop/computer you’ve been using to another location and then the Windows driver was gone(no longer installed)? Was there a VooDoo doll involved?

If it has to do with electronics, if it can be broken, Ill find the way, lol. Moved the laser to a new spot and now the computer/LIBusb do not see the laser connected to the computer.

1 Like

If you have a raspberry pi, you could try attaching it to see whether it recognizes a USB port. Linux has a different approach to USB devices than Windows.

As fat as I am you would think I would have one… But I dont have one, still not sure what it is… other then a really good pie… lol

Another possibility: #k40:meerk40t uses a different approach than #k40:k40-whisperer to talk to the USB device. You could test and see whether it can find a device; that might tell you with a bit more certainty whether the problem is a hardware problem on the board or a software problem in Windows.

since you have nothing to do while you wait for a new board, why not try making a bootable version of Linux on a USB stick and then you can do what Michael was mentioning. ie use Linux to look and see if the M2Nano USB is still functional.

2 Likes

Does anyone know if this board will work? If so how do you go about getting it to work?

Whisper only works with a nano board. The one you reference would use a program like LightBurn.

1 Like
  1. Look in Device Manager - you may have to find the option to show hidden devices. See whether a device appears / disappears when you plug / unplug the K40.

  2. Check the USB socket on the K40 and see if it is loose - I hear that they have a habit of breaking loose if they have stress put on them.

2 Likes

Thank you for the help guys. Got my new board in today and she is working right along. Now to fight with the seller about their faulty board! :slight_smile:

4 Likes