Chilipeppr g2core 100.xx compatibility

Sry if these have been answered several times but as a fresh g2core + Chilipeppr user it’s been somewhat confusing to get anything working with mixed guides and surprisingly little discussion (is this an abandoned combo?).

HW setup: DUE + Grbl shield v3.0 with 4x DRV8825

First, it wasn’t that clear that only option to get anything working was a custom build as it’s not stated anywhere that g2core prebuilt bins have all motors disabled etc. (what’s the use to have those anyway?). Then no mention that common enable pin has been disabled at some point. Then that the 87.xx fw available trough CP updater doesn’t really work that well (pause & resume makes everything freeze every time). To make me more confused CP FW updater worked yesterday but today it just failed to download. It jumped to 100% from around 40% and DUE just showed up as an Bossa Program Port in devices, which first made me thought that my build had failed but what since turned out to be a sign of corrupted download. Used bossac.exe since without problems.

Anyway, tried to build custom config using 101.03 from edge branch. I adjusted motor & axis settings, disabled common enable pin, mapped motor 1 enable to grbl shield enable pin, changed motor 1 enable to original common enable pin and set motor 1 power mode to MOTOR_POWERED_IN_CYCLE. Downloaded the bin to DUE and Chilipeppr recognised it, but told that I should be using some 440fw for my TinyG, so didn’t really identify it as a G2 board. Motors didn’t move and noticed that the configuration in widget didn’t match the setting.h I had compiled against. I did get motors running by changing stuff from widget but something clearly isn’t right. Also noticed random crap like ‘motor energize button’ not working (worked with v87.xx). Feedhold & resume seemed to work.

So, what g2core branch should I be using with Chilipeppr? Should I be using it at all? Maybe I shouldn’t even care about config not working and just set the right values from Chilipeppr, but I don’t know where my settings get saved (or if they do) as I can’t set up any personal workspace because it says I need to login, which I can’t do as the CP login button does absolutely nothing.

Partial success.
I got the CP config widget finally matching my build settings. Seems there’s something wrong with the settings_default.h or it includes something that causes hiccups during interfacing with CP or then it was just a glitch in the matrix but I’ve now built several different configs using shapeoko2.h as a base instead and almost everything seems to work. I did use ‘make -B’ every time to make sure everything gets updated.
Motor energizing buttons are still dead but at least axis & motor settings are now correct right from the start.

1 Like