Anybody ever lose a mosfet on their RAMPS board?

Anybody ever lose a mosfet on their RAMPS board? I’ve been systematically narrowing down a nasty printer bug and I’m starting to suspect stuff in the power supply chain.

Trying a replacement PS now, but I’m curious if anyone’s seen one of the mosfets give up the ghost?

It likely could be the poly fuse. The can stick in a 1/2 tripped state. Jump across the leads and see if the problem clears up.

I have had 2 mofsets fried on my ramp boards. Replaced with a comparable FET from Digikey and worked like a charm.

So for what its worth, if the FET is in the TO-220 package and isn’t protected by a heat sink, the most current it will be able to handle will be about 10A. You can get that number by taking the max RDS on (it hits max when the part is at max temp), and using 2W as the amount of heat the TO220 can dissipate at room temperature, using P = i^2r and solving for i you get 10A. Try to do more than that and you’ll toast it. There aren’t any cap’s on the power leads for fan loads either so you need to be careful about voltage spikes when you turn off the fan. A 10uF low ESR cap between power and ground near the FET would probably do wonders for FETs powering fans.

One of mine failed. Here is how I fixed it:

I now also have an 80 mm fan blowing over the ramps.

I think many, many people have failed MOSFETs. Search the reprap forums…

My setup:

  • polyfuses OUT
  • 12V car fuses IN (10A/5A)
  • Heatsink on MOSFET
  • FAN blowing next/over RAMPS
  • Diodes on heat bed / extruder connections

I did these even before testing the board.

Some of these are documented mods on RAMPS 1.4.2

So far so good.

Same with me. Before use i remove the poly fuses and replace with jumpers. Replace the 30A hotbed MOSSFET with a 150A IRLB8743 MOSSFET, add a 2 pin header to the constant 12V output to use with the E3d fan.

Cool, thanks for all the feedback!

I’ve been working on solving an ongoing problem that looks like it could be caused by a million different problems, but I’ve addressed all known causes and for about a month I was out of ideas.

Then I noticed than when the printer is running the fan I use to cool my j-head’s fins would change speeds occasionally and breifly while the printer is operating. This fan is connected directly to the 12V 5A input on the RAMPS board (just upstream of the connector, hard-wired to the power supply cable itself) so its speed isn’t being controlled by software or anything like that.

Once I noticed this and put 2 + 2 together the only cause for the change in speed that I could think of would be that the power supply voltage was dropping, which tells me that it’s not supplying as much current as the printer is demanding. Upon inspection the power supply was hot, so I suspected that and replaced it with a beefier one.

So, maybe the power supply is providing the full 5A but the printer is drawing more? Or maybe I’m wrong about the conclusion I reached regarding the changing fan speed?