X-Max3 fails to boot after attempted software update

Hey guys, Daniel here. Need some help. Yesterday I installed Obico via SSH to my X-max3. After that I notice some updates(Klipper and Moonraker) available on Fluidd, Did them, huge mistake. (MCU Protocol error This is frequently caused by running an older version of the firmware on the MCU(s). Fix by recompiling and flashing the firmware.

Sooo, I reinstall the latest version of the firmware and now I only have this message: THE SYSTEM STARTS ABNORMALLY. Printer won’t Boot and I can’t access it using Fluid or SSH.

contacted QIDI and they sent me a MKSCLIENT recovery file, with no success. Any tips??

It’s really annoying that they haven’t gone the last mile for making this printer Just Work with upstream and be able to take updates. I think that they are dependent on Makerbase who are probably where this restriction comes from.

Qidi are pre-selling a 32GB version of their EMMC board with a USB adapter:

That links to a version of the part you can buy now on aliexpress but at least to the US that has a projected delivery between November 28 and December 4.

It also provides a link to download a new image to write to EMMC. That would start over from scratch on updates, but I’d hope it would get you going. I think that you could get any Makerbase EMMC adapter and use it to write a new image to your existing card.

I haven’t found a replacement 8GB EMMC module that definitely declares itself to be compatible with Makerbase. It might be that the common modules for the nanopi are electronically equivalent?

Oh, I just found this one with a comment:

EMMC card and adapter both worked although I would have preferred a USB interface for the adapter over the microsd. Got this for a qidi x plus 3 printer, just right before they released their own. Securing screw in the wrong place but this can easily be held down with a printed bracket.

You can see the different mounting holes in these pictures, of the Makerbase unit:

vs. the NanoPi unit that is apparently electrically compatible but would need an adapter for the Qidi:

That probably means that you could re-flash the images they provide with any nanopi-compatible microSD or USB adapter and those seem to be widely available and cheap.

One of the many youtube reviews linked at the top mentions that the reviewer did an update and that Qidi sent him a new EMMC module. So really since they don’t tell you in the documentation not to do normal updates, they should send you one for free as well. It’s most definitely their fault for shipping a unit that shouldn’t be upgraded, and then not mentioning it in their documentation.

That’s a really bad security practice, and eventually it would be nice to make the system upgradeable. But in the meantime, I placed an order for the 32GB module the moment it came out so that I’ll have it on hand if anything goes wrong…

Hope that helps!

Michael, that helped immensely. Already order the 32gb Emmc and im looking for an adapter to flash this existing one. So far, Qidi only give me instructions on how to repair Klipper and moonraker, but if this Emmc is busted as I suspect, I will ask them to send me a new one.

Tks a lot for you help.

Have a great day.

1 Like

If you can’t ssh in, it’s hard to fix…

I wonder whether it would be possible to flash a system image to a microsd card and boot off that? The MKS SKIPR on which the X-4 control board seems to be based supports booting from microsd. You might be able to:

  • Write the system image to a microsd card
  • Boot with the microsd card installed
  • Use ssh to get into the system running from microsd
  • Write the system image to the EMMC module from the system running on the microsd
  • Reboot without the microsd card installed.

That’s just a thought, nothing I’ve tried.

In any case, it would be only the contents of the EMMC that are the problem, so if they send you a new EMMC module, you could still use the old one as a backup — you would just need to write a new image to it.

That sounds a bit too advanced for me, I just learned how to ssh couple days ago. LOL

I got a windows pc now and will try to ssh using ethernet, since Macs don’t have ethernet ports anymore and using terminal to ssh is kind hard. if that don’t work I will try your way.

Ah, yes, updates are set up to overwrite the wifi configuration. That’s a very annoying design defect of this system. I ended up connecting mine to wired ethernet permanently.

No luck Michael, the system doesn’t recognize the sd card as the main boot image. I even try to boot without the EMMC on. Got the same message on the display and wasn’t able to ssh. I guess I will have to wait for the new EMMC card arrive once I wasn’t able to find an adapter to flash the old one here in Brazil.

I’m sorry! I wish it had worked. I hope the new EMMC card arrives soon! :crossed_fingers:

Hi Daniel,
Did you end up with a solution to this issue?
I am having the same issue now with identical steps to get there.
Install Obico,
Update in Fluidd,
Update causes MCU issues,
Flash using firmware from Qidi website,
No longer boots and instead shows abnormal boot error.

I replaced the EMMC, you can try to flash yours, but you will need the makerbase adapter.

I believe the better option is to buy the 32gb Emmc. That’s what I did. Along with it, comes the adapter to flash your old EMMC, so you end up with a spare EMMC.

1 Like

I did the exact same thing and am stuck. Can you explain to me what I need to do? Thanks!

did you find a solution, I have the same problem

Buy the 32gb EMMC from Qidi. You will need to update the system with the latest software after installing it.

Hi there i have bought the 32 GB Module from QIDI tech direcktly (beside from some custom problems , had to pay an extra fee of 26€ ) . I replaced the EMMC. But when it boots up its a brick. When is switch on the Qidi X plus 3 it runs into booting cycle and is unpacking the image in an grey screen.of progress, this comes than to 100% end.
And the Display is popping up in the blue scren of Failure Diagnosis…But i cant do noting on the screen it shows only
error:
nothing more i cant actuate firmware restart or klipper restart.
When i switch off and on it runs into depacking the image again .
Cant adjust WIFI or other things cause the softkey to setting dosnt work.
Any suggestions.

@Logiclinux Are you following QIDI’s instructions for writing an image to the EMMC modules? I believe that the modules don’t ship with an image installed because they are applicable to several printers, and you have to choose the right image for your printer.

Here’s a script for recovering in many cases without replacing the eMMC