S Axis instead of Z axis?

This might sound like a stupid question but I can’t seem to find a solution anywhere. How do I get a Z axis?
I fitted a MKS DLC-32 board to run a Homer CNC router machine. After some teething problems (Trying to get the motors to work) I managed to get the machine going via the small control screen (Jogging etc) when I open the app (MKS Laser) on my phone there is no Z axis, Just X,Y and S…It’s the same when I connect to the ESP32-WEB wifi control, there is a X and Y Axis a MX and MY and a ‘S’ axis, but no Z.
I thought it was because it was designed for laser use however, I watched a YouTube video this morning where someone opened the Web control and there large as life, was a Z axis on the screen.
Can anyone tell me how I go about configuring a Z axis? Oh and by the way the settings menu on the ESP- WEB 32 doesn’t open either the circle just goes round and round…Which I’m guessing is where the problem starts.
MacBook Pro M3
Board Version: MKS DLC32 CNC V2.0
Firmware: V2.1.0(8M.H24.20220511)
Thanks…

I don’t have this board, so I can provide only minimal help. But this might get you started.

They provide a version of Bart Dring’s Grbl_Esp32 for the firmware.

Here’s the documentation for Grbl_Esp32:

Unfortunately, they did not fork Bart’s repository to start, so it’s not easy to see what changes they made. MKS have an unfortunate habit of making it hard to use the source code they modify in this way. :frowning:

Their documentation is also not great, but such as it is:

1 Like

I have the same board and after digging around, I gave up and installed Fluidnc on it. You give up the use of the screen but it is soo much better to work with

I finally decided to upload Fluidic onto the board but can’t find the yaml config files for DLC-32 config in the download from Github (Latest Ver).
In the FluidNC Main folder I found the example configs folder, where I was expecting it to be, but it only contains quarto.yaml file, and I can’t open that. Have you any idea where I can find the Config.yaml file. Github says the put it into a new repo (whatever that is). Newbee alert.
Regard.
Peter.

Did this problem ever get resolved? I’m in the same boat with no z-axis and no connect to the browser control after setting up wifi. I NEED Z-axis. I run the board on my CNC plasma cutter.

Hi Robert,
I followed the heard I’m afraid and loaded Fluidic. It seemed to be the only way to get over the problem as I exhausted all avenues to find an answer. As for the config file problem, I searched Github for Config examples and used the nearest to the one I needed then altered it to suite. I do find it a bit glitchy but I’m not sure if it’s my setup. As this is my first self build it’s still a bit mysterious how it all works but I’m getting there. If you are using UGS to send files to your machine you might be better loading GRBL ESP32. I keep getting a message that UGS does not know how to configure Fluidic, it works if you load it manually but some things don’t run, can’t remember off hand. These are both latest versions of Fluid and UGS as of today.
I hope this info helps…best of luck.

1 Like

Thanks Peter. The problem with the ESP32 controller is the lack of the Z axis. Currently I just use Open Builds Control to set the z-axis and then switch over to the ESP32 mobile app to run it. I would just run everything from Open Builds Control, but the plasma machine screws up my computer and the project stops after about a minute into it. But just running the file right off the card on the control board seems to work just fine. If I create the G-Code file in Open Builds Cam, and then upload it to the control board card, it manages the x Y and Z axis without an issue. But that workaround of having to hook up to Open Builds Control first just to set the Z height is a real pain. Sure would be nice if I could just do it right on the ESP 32 controller app.