OrcaSlicer support for Qidi printers

I just checked and Qidi 3D printers are supported as defaults in OrcaSlicer too.
But there was a bug in the JavaScript code which is now in the 1.7 dev beta which can be found by going to “Actions”, then select any completed action with a green check-mark and scroll down to see the artifacts where you’ll see the Linux build in a zipfile( zipped AppImage ). Latest is here if you want to try it: Update Korean translation (#2022) · SoftFever/OrcaSlicer@dadec13 · GitHub

1 Like

Yes, Bambu pulled the Qidi support from Orca with commit 4733a9a60287 and that itself has been merged back into Orca, so they are in sync, and it’s good to see that Bambu are working with open source developers at least there now, even though they are doing their best to lock down other parts. And Qidi themselves recommend OrcaSlicer as an alternative to their own slicer. Good for them!

I’m a little sad that Orca doesn’t seem to have any way to disable the pane for the Bambu cloud binary plugin. It shows as if it were an error. :frowning: No, really, I don’t want that. :grin:

1 Like

Yes it’s good to hear they are working with the open source projects and especially OrcaSlicer.
I didn’t notice a Bambu pane and will recheck. One other problem I’m having is how long it takes to start up. I quickly get the main window with menus, etc but then it goes black for over a minute. But when I first started it and ran the setup I did not enable or add the Bambu process.

Ah, you mean on the Home page of the slicer where it shows a narrow pane on the left for Login/Register into the Bamu Network. I’ll look to see if there’s anything in the OrcaSlicer.conf file to disable that. UPDATE: I didn’t see anything which changed that but will look for commandline options which might do something. Only things of interest networking related were
“allow_ip_resolve”: “0”,
“developer_mode”: false,
“enable_ssl_for_ftp”: false,
“enable_ssl_for_mqtt”: false,
“internal_developer_mode”: false,
“iot_environment”: “1”,

Just a shot in the dark but neither of these worked: :slight_smile:
“show_login_window”: false,
“show_bambu_window”: false,

added a feature request:

option to hide Bambu Network login window pane #2032

1 Like

I just noticed lots of this in the console when running OrcaSlicer:

* Connected to e.bambulab.com ( port 443 (#0)
* ALPN, offering http/1.1
* ALPN, offering http/1.1
* SSL connection using TLSv1.3 / TLS_AES_128_GCM_SHA256
* ALPN, server accepted to use http/1.1
* Server certificate:
*  subject: CN=*.bambulab.com
*  start date: Jun 15 00:00:00 2023 GMT
*  expire date: Jul 14 23:59:59 2024 GMT
*  issuer: C=US; O=DigiCert, Inc.; CN=RapidSSL Global TLS RSA4096 SHA256 2022 CA1
*  SSL certificate verify result: unable to get local issuer certificate (20), continuing anyway.

It looks like at least some of those javascript errors are from OrcaSlicer reaching out to bambulab’s servers, even though I don’t have a Bambu machine. Black-holing e.bambulab.com I think reduced the number of javascript errors I ran into when starting it.

I get a quick flash of black, but most of the time it takes it to start for me is waiting to tell it to ignore the javascript errors. Maybe as much as five seconds, of which three is the mouse clicks? Definitely not a minute for me anyway.

1 Like

my little MacBook Air only has 4G of RAM so it’s straining on this huge app. PrusaSlicer starts quickly but this takes many minutes with a black window before it presents the home screen. And when it does, boy does it choke on a bunch of gtk things. Many hundreds of lines of gtk errors.

$ ~/Downloads/OrcaSlicer_ubu64.AppImage 
[2023-09-07 20:37:23.007773] [0x00007f994f398e00] [trace]   Initializing StaticPrintConfigs
add font of HarmonyOS_Sans_SC_Bold returns 1
add font of HarmonyOS_Sans_SC_Regular returns 1
add font of NanumGothic-Regular returns 1
add font of NanumGothic-Bold returns 1
loading network module at /home/maker/.config/OrcaSlicer/plugins/libbambu_networking.so
error, dlerror is /home/maker/.config/OrcaSlicer/plugins/libbambu_networking.so: cannot open shared object file: No such file or directory
after dlopen, network_module is (nil)

(orca-slicer:104413): Gtk-CRITICAL **: 20:37:30.789: gtk_window_resize: assertion 'height > 0' failed

(orca-slicer:104413): GLib-GObject-WARNING **: 20:37:30.941: invalid cast from 'wxPizza' to 'GtkCellLayout'

(orca-slicer:104413): Gtk-CRITICAL **: 20:37:30.941: gtk_cell_layout_get_cells: assertion 'GTK_IS_CELL_LAYOUT (cell_layout)' failed

(orca-slicer:104413): GLib-GObject-WARNING **: 20:37:30.944: invalid cast from 'wxPizza' to 'GtkCellLayout'

My other machine is a 16GB i7 with NVidia GPU so I booted a 22.04 iso image and built OrcaSlicer.
Only issue was they missed ‘build-essential’ as a required package. This machine also starts OrcaSlicer much quicker with just a few seconds of the black screen. But it’s odd how it first shows a normal OrcaSlicer window then it gets covered up with the black window.

1 Like

BambuStudio has the same behavior, showing a splash window, then a black window, and then after a few seconds the working UI. This happens on three Fedora machines of varying speeds.


I’m going to dig into their code and see WTH they are doing. Gotta figure out their make system to see if it’ll do incremental builds since it took hours to compile the code from scratch.

1 Like

Sigh. It’s pretty clear that OrcaSlicer is Bambu-focused.

Closed #2032 as not planned.

1 Like

exactly because nobody else uses Bambu’s login and even when using Bambu in LAN-only mode there’s nothing to log into. I was not thinking that Orca devs were so tied to Bambu. Or maybe Bambu devs expressed dislike to removing or hiding any of the Bambu stuff so they didn’t want to upset the cart since it’d probably be more work should Bambu no want to play any more. but just speculating…

Hi Everyone, I’m having some issues connecting my new QIDI Q1 pro via WiFI in Orca slicer. In the Qidi slicer the printer is seen in my network, but Orca doesn’t find it.

My Settings are all on default, and the protocol is Octo/Klipper, any suggestions?