[OpenPnP] Smoothie board + OpenPNP help

Hello guys,

I’m new in the smoothie world. I have smoothieboard 5X and I want to connect it to pick and place machine. I am using openPNP software. what I did is :

1 - I downloaded firmware file " Smoothieware/FirmwareBin at edge · Smoothieware/Smoothieware · GitHub "

2 - I downloaded config.txt file from “configuring-smoothie [Smoothieware]

3 - I copied the file firmware.bin and config.txt to a micro-SD card.

4 - I run it >> it was flashed successfully, where the filename changed from firmware.bin to FIRMWARE.CUR The config.txt will always remain config.txt.

5 - I connected the card via USB cable to my laptop.

6 - I ran smoothie board with Pronterface application. I can connected to the board via serial board.

My problem is I want to move any x , y z motors just to check the flushing or the board is ok , but NO movement has been occurred. I mean no motor run when I send command via this software to the board, where the Gcode drive configuration for the serial board is ok. Can anyone telling me what I did wrong or any help please just to have any motor running in… Your help is highly appreciated

Could you please provide your config.txt file?

Please just paste the whole thing into the response window between lines with ```like this:


That will format it to be easy to read.

Thanks for your reply.

The X,Y and Z are working now after adding the line :

Fix for incorrect Digipots used on Smoothieboard Clones.

digipot_factor 36.6

in the configuration file according to the link:
[ Aliexpress FYSETC smoothieboard V1.1 MCP4441 issue ]
about the smoothieboard V1.1 MCP4441 issue

Considering you’re also asking this on the OpenPNP forums, and there was a faster/more complete set of answers/helpers there, I’m going to keep things over there. Anyone running into the same issues, you can search over there to find the topic.

1 Like

Thanks Arthur !

Hello Everyone, I return to post my problem here as well. as i mentioned before after run the Smoothie board by " Pronterface application" I am trying now before to install all te motor in my machine , I want to run them by OpenPNP. till now the document of OenPNP doesn’t help me to run at least x and y motors. I would asking here what is going wrong with my steps and what I have to do to get that ? . After my discussion in OpenPNP forum I understood that the software doesn’t send any command to the board, but i noted that X motor is running only ones time when I shut down and running again the OpenPNP. Thanks for your helps

1 Like

Hi All,

My question is posted in OpenPNP forums but No answer, so
I am trying to run the Z axis but not succeed, where this axis is connecting as a rocker. I am not sure what the value of the [ gamma_steps_per_mm ] in the configuration file should be. Any idea of how I can config Z axis ?and how I configure both rotor motors of the nozzles in the machine axis where I configure it as showing below:


Thanks for help!