Open source and other toolpath software

I run Linux and have written a good deal of open source, so I rather like starting projects with Linux and open source…

I successfully toolpathed my own designs for my first CNC project all in FreeCAD, end to end. Worked great!

Now I’m trying to take an opendesk design provided in a DXF file and toolpath it. This is proving more challenging. I was able to use LibreCAD (QCAD fork) to lay out the pieces to fit my router’s 775 x 1270mm workspace. Then the fun really began. I’ve been tearing my hair out with toolpath generation trying out open source options:

  • FreeCAD doesn’t recognize some of the polylines are closed when importing the DXF, and if I use inkscape to convert from DXF to either vanilla SVG or inkscape SVG, FreeCAD crashes (segfault).
  • jscut I can’t select the parts because it expects them to be filled
  • inkscape gcodetools doesn’t actually handle tool diameter and isn’t really set up for cutting multiple parts with multiple operations
  • pycam picks up some random bits of line segments and generates garbage
  • HeeksCNC latest I failed to build because it is based on older WxWidgets, I think
  • PathCAM fails to build (hasn’t been touched for years)
  • OpenCAM is written in BASIC and hasn’t been touched for 13 years so I’m not even looking
  • I’m honestly losing track of the rest of the tools I’ve tried or stopped short before even trying…

So I think next I’m going to look at non-open-source gratis and trialware. I’m not opposed to paying for software, but I don’t like paying for software that’s inconvenient for me to use (for example, doesn’t support Linux) or that I am not confident ahead of time will do the job. Especially not both at once.

CamBam is the only one I’ve found that runs relatively natively under Linux (packaged up with mono explicitly for Linux). Carbide Create was rumored five years ago to run under Wine, so that’s a possibility. Vectric products have free trials so I could find out. Fusion 360 looks like a rather heavier weight solution that I’m less confident in running under Wine, and I hesitate to “get comfortable” there because I’d worry that at any point they could turn off the gratis license, so perpetual licenses are more comfortable. Booting Windows on my laptop means running it in a VM off a USB drive, so I avoid it when I can… :slight_smile:

CamBam starts under Linux, but the very first run says “Your evaluation has expired. Please run CamBam as administrator for the evaluation count to work correctly.” That’s liable to make it hard to actually evaluate. And it won’t let me select the Tool Profile; I select “End Mill” and it returns to “Unspecified”. That seems unlikely to have been missed in a version out since June, so most likely it is limited to the Linux edition. [Problem did not reproduce under Windows, so yes, it’s just on Linux, could be a bug in the mono implementation of .NET] I guess that isn’t a slam dunk.

Dolphin lists more hobbyist than pro users, but doesn’t list a post processor for grbl.

Carbide Create got me an email pretty quickly to sign up for their newsletter as a prerequisite for their free trial, but the followup email with download link hasn’t arrived at this point. So I’m still waiting to find out there. … Arrived the next morning, but there’s no ability to configure arbitrary machine sizes; you may use it for any machine, but it only has size presets for Carbide 3D’s machines. This is fine but makes it a non-starter for my machine! :slight_smile:

I run Vectric Aspire under Windows and I love it. Have you considered possibly just dedicating a PC to the CNC router and running windows on it? That would open up a world of possibilities for you.

I’m awake an hour and a half after I intended to be, without a clear end in sight, because of Windows updates. I keep forgetting how terrible Windows is between uses. I can run it on a VM on my laptop rather than dedicate a separate machine to it; then I can carry it with me.

@mcdanlj Have you tried LaserWeb? It can be used to place parts and create toolpath. But it also has problems with some invalid svg.

@cprezzi Oh, yes, knew I was forgetting something in that list!

It was certainly able to read the file, but it wasn’t obvious to me what I would need to do to configure it for CNC (for example, tool configuration) and do pocketing operations (including after selecting a feature to pocket). And forgive me if I misinterpreted, but I got the impression that you said that the UI portion no longer had an active developer, which makes me worry about investing in learning something and then it not keeping up with “evergreen” browser technology and just not working any more after some firefox update. [Also: I just saw that it’s intended only to work on Chrome?] So I didn’t spend a lot of time when it wasn’t obvious how to do that.

CamBam crashed so hard that windows is failing to shut down. To be clear, I blame Microsoft not CamBam for it being possible to do that. I’m wondering whether I’ll use up the 40 trial sessions before even successfully creating a gcode file! :roll_eyes:

Second try worked better. My crash did use up a demo session. There are some oddities involving units. The built-in “tool 4” is labeled as a 0.25" tool, but it is modeled as a 0.25 mm tool. The UI could use some units on things like feed rates, but feed and plunge seem to be in mm/min. The default values sure looks like inches (clearance plane of 0.125 for instance) but are actually mm (0.125mm is a rather short clearance plane in my opinion…) It’s usable!

It’s true that both frontend devs (Todd and Jorge) moved on to other projects, but it’s in a mostly stable condition with most needed features and it’s open source.

You don’t need to switch between laser and mill mode. You just need to make the settings for your machine once and then use the corresponding CAM operations (like Mill Pocket).

The default installation doesn’t need a browser to use because it’s an executable that has a chromium browser integrated (with electron). So no conflict with browser updates.

1 Like