Need some help with Novusun NVUM CNC Controller and Mach3.

ox-help
ox-faq
ox
gplus
(Michael Durie) #1

Need some help with Novusun NVUM CNC Controller and Mach3. Im installing this on a Workbee CNC (very similar to the OX). After calibrating and making a small test pass. it appears to be losing steps during a 3d carve. Ive adjusted the Motor Tuning, reduced the depth of cut, Checked all the screws. Im not sure what else to check. Supplier suggested that maybe a wheel is causing a jam, Everything moves smoothly. Any suggestions or Ideas?

(Ariel Yahni (UniKpty)) #2

Do you have an image that shows the lost steps?
What material are you milling? Speed?

(Darrell n) #3

What do you have your stepper drivers set for in terms of microstepping? I find that 1/8 microstepping is about max to maintain sufficient torque. Also, you should be running motors on 24v instead of 12v for maximum torque. You don’t mention what kind of stepper drivers you are using, or does the Novosun have them built in? What current are you running the motors at?

Lubricate your wheels, screws, and tracks with a dry lubricant
(teflon)

MG

(Michael Durie) #4

Using the TB6600 Drivers that came with the controller as a kit. My Pwr supply is a 24V PS, however the connections from the Drivers go to the controller, not the PS. Motors are Nema23 Steppers. My DIP switches are set to 16. had them at 8 and still did same thing. Current is set to 2.8A

(Michael Durie) #5

@Ariel_Yahni_UniKpty Here is a photo of the roughing pass. It seems to mainly on the X Axis. Mark center of the board. Set HOME to that center, after rough pass finishes returns to home, but the bit is about 1/4 inch to the left of center on X Axis.

3bac29e6d347ae09788dcb56c3dc8793.jpeg

(Darrell n) #6

@Michael_Durie You should have each stepper driver power input wired directly to the power supply thru 5A fuses. Do not daisy chain driver power together, run separate wires to the supply for each driver. I wouldn’t recommend taking driver power from the controller, because you could be drawing almost 12A if all 4 motors are running at once, who knows how thick the traces on the controller board are?

I also think you should use maximum 1/8 microstepping. I wouldn’t use 1/16 unless you have high torque motors. Check the motor and driver wiring to make sure you don’t have a loose connection on the motor leads or one of the driver inputs.

Do a simple g-code program with just a few circles and squares, run it, and measure them for size. Circles should be round and same radius all around, squares should be square and same width as height.

Check to make sure all axes have zero play by grabbing the carriage and trying to move it side to side, forward and back, and up and down. You should not feel any “clicking” or free play in any axis.

Wheels should be tight, but you should still be able to turn them manually with your fingers. If you can’t turn them by hand, or they are very tight, back off the adjusters a bit. Check the locking collars on the leadscrews to make sure they are tight and not allowing end play on the screw.

Make sure your USB cable is as short as possible, and has ferrite “lumps” on it to reduce noise.

Don’t plug the router into the same outlet as the machine power supply and laptop.

MG

(Michael Durie) #7

Correction, the Drivers are wired to the 24vdc on the PS. I was mistaken. the +V has 3 terminals and the -V has 3, 2 drivers are wired to each terminal. The Router relay is wired to the Output of the controller and the AC is wired directly to the AC line IN of the box. Dont know if this makes a difference or not, but Im running Windows 10 64bit with 12 GB of ram.

(Michael Durie) #8

Update: I did some test cuts using Circles, squares and Rectangles. Found the speed that it worked best at. ran the path multiple times and each time it homed properly and even stayed in the same path as the previous cuts. Cutting 2 mm deep into Cherry wood. So I went ahead and made a small 3d pattern, Rectangle with 3 stars. It did the rough pass without incident until it was done, it returned to home and it was 3 mm to the left of center mark. Reset the home position to be my center mark and started finish tool-path. While running at approximately 50 lines of code in, the router stops moving. I look at Mach3 and then the status bar says USB DEVICE CONNECTED and the router takes off again. At this point i know my positions are screwed so I stop the test. How can a 2d cut work, but a 3d not? I am totally lost here…

38afb7fea011131d0ead236eed19773f.jpeg

(Michael Durie) #9

284613239f6c4b3a770602531067fa78.jpeg

(Michael Durie) #10

50553c53d410d4fb9ec98152a0b4471e.jpeg

(Darrell n) #11

@Michael_Durie What do you have your motor acceleration set to? I would suggest no more than 50 or 60 mm/sec^2. What is the motor maximum speed? Here I wouldn’t use more than 3000-3500mm/min with standard 1.2N/M motors.

You may need to increase the pulse width on the motor pulse output, I don’t know what the specification is for the NVUM, but if the pulse width is too short, it may miss some.

The router doesn’t know the difference between a 2D and a 3D cut. It’s just executing the g-code sent to it. From your description, it may be something to do with the USB connection. If it loses connection, it would cause it to stop executing. As I said before, use the shortest USB cable you can, keep it away from power cords, and make sure it has the ferrite “Lumps” on it. Check to see that your USB port is not damaged, laptops seem prone to baked USB ports. Try a different port.

Also, Mach 3 is famous for hiccuping if you are running other applications at the same time. Make sure nothing else is running but Mach3. No surfing the web or recalculating spreadsheets while Mach3 is running. Your computer has lots of RAM and sounds like a fairly fast machine, so that’s not likely it.

There may be some settings in Mach3 General Config or Plugin Config screens that you have to tweek.

Google “NVUM controller and Mach3” to see if there are others with problems like yours.

(Michael Durie) #12

I believe the Motor tuning for X is 397.9999 1800 500 they other 2 boxes are 0 and 0

the usb cable runs for the PC USB port under the table up through a hole and conncets to the controller in a box. it has the ferrites on the cable and Ive even tried a shorter one with same issues.

(Darrell n) #13

@Michael_Durie 500 is way too high for acceleration. As I said, no more than 50 if you are set to mm for units. Perhaps tyr putting 5 in the pulse width box

(Michael Durie) #14

@Darrell_n Yes I am Screw driven and in MM settings. Why would the Acceleration be so low as 50? this unit should move quite fast from my understanding.

(Darrell n) #15

Acceleration and fast movement are two completely different things. You need to overcome the static and dynamic inertia of the system. If you try to accelerate too fast, the motors won’t have enough torque, and it will lose steps. 50mm/sec^2 is respectable acceleration. 500 mm/sec^2 would not be attainable even with 365 oz/in motors. If you try to accelerate the system beyond the capability of the motors, it will lose steps. Simple as that.

Stepper motor torque curves drop off almost linearly with speed. The motor has only a fraction of the torque at higher RPM’s than it does at at stop. Also, torque drops off with higher microstepping numbers as well. If you combine high microstepping rates, small motors, and fast acceleration it is a recipe for lost steps.

If it doesn’t meet your expectations, get better hardware. I’ve never trusted cheap Chinese controllers because they have poor software and poor hardware design and refuse to fix bugs. Spend the money and buy an Ethernet Smooth Stepper or something similar if you want the best performance.

I have built over 40 machines, including half a dozen WorkBee 1000x1000’s. This is obviously your first. If you don’t trust my advice then don’t use it.

MG

(Michael Durie) #16

No please do think that Im disagreeing with you at all. I was asking because I dont know. Your explanation makes sense.

This is my 2nd CNC, the first came preassembled and had documentation of what to put where in mach3, this is my first self build. I trust your experience that is why I came to the group to ask more experienced personnel.

Ive changed to Accel to 50 and I see a difference in the movement. Now to test a piece this evening. I will also change the Drivers to 1/8 steps.

and this is a WorkBee 1000 x 1000. its awesome that you picked it right out.

(Darrell n) #17

@Michael_Durie Ok. Sorry I got grumpy but its been a bad day.

It’s always better to start off with conservative settings and slowly increase them until you find the limits of your machine. Even with 265 oz/in motors (about 50% more torque than yours), I don’t generally increase the acceleration past 75 or 80. I’ve never actually tested it to “destruction” to see how much I can crank it up. The acceleration doesn’t have a huge effect on the performance of the machine, and it’s better to be safe than sorry. You can usually tell if your acceleration is too high because you will hear “thumping” or “groaning” noises from the motors when they change direction or start up. This is usually steps being lost.

I never asked, but does this only occur on one axis, or both? The Y axis has 2 motors, so more power, but also more weight to accelerate. One thing to check is to see if your Y axis goes out of square, or racks. Measure the distance from each gantry plate to the end of the axis (use the same point on both sides), if your gantry is square it should be equal. Now run it at high speed from one end to the other several times, and check it again. If it’s changed, likely one motor is losing steps.

You can do the same with the X axis, run it back and forth several times measuring distances from the carriage to the side plates before and after. If the distances are not exactly the same before and after, you are losing steps.

You can write a little G-code program to do this, both axes at once. Run it back and forth say 10 times, then measure distances and compare to the “before” readings. Don’t rely on the Mach3 display, it will show the right number of steps since it only measures what was sent, not what actually happened. Use a good ruler or trusted tape measure.

Once you have established the baseline speed/acceleration works ok, you can start cranking it up and trying it again. When you find a discrepancy, back off your acceleration by 20% and call it good.

BTW, lubrication helps a LOT. Lube the screws and wheels/tracks with a good dry film lubricant, similar to what they use on guns. It dries completely, leaving a dry teflon film that doesn’t attract dust. I use WD40 Specialist Dry Lubricant, but CRC, LPS, and many others make equivalent products. DO NOT use plain old WD40, it could deteriorate the polycarbonate wheels, and it attracts a ton of dust.

MG

(Michael Durie) #18

From what all tests indicate, is that its on the X axis after the rough pass finishes. It should return to 0,0,0 (home) and when it returns its 3mm to the left of the mark on X axis. Y seems accurate. On just a simple toolpath test, it returns to 0,0,0 without issues multiple times.

I will see if I can find the WD40 Dry Lube locally.

(Darrell n) #19

Double check that there is no play in the X axis carriage. You will typically see problems only when the carriage reverses direction, this is when any play in the axis will reveal itself. Strange that it is exactly the same distance every time, and that it is farther than the axis was supposed to move. I would have expected it to be less. That is not consistent with losing steps, it is more indicative of play somewhere in the axis.

Check your flex coupling on the motor to see if one of the setscrews is loose. Check the leadscrew nuts for play, and the lock collars on the ends of the leadscrew.

MG

(Michael Durie) #20

Im going to change the Steppers to 8 tonight and redo the calibration on motor tuning to match. then I will try a simple test and advise. On the step pulse 1-5 us and Dir Pulse 0-5 what do you recommend for these values, I did not have any info on these so I left them blank.