Machine wont power on

Hi folks…been having fun with my k40 until this afternoon. Kind of puzzled… machine would not power on…took out fuse at power inlet…can’t really tell if it’s blown. If not this would it possibly be the power switch itself…or…???

Thanks for any suggestions

Once using this machine it’s hard to quit

Cheers

Greetings Roger and welcome to the forum! :slight_smile:

Is your machine stock? Can you provide some pictures of the front of the machine and your power supply?

Also would suggest going though this guide to cover most issues associated with power.

Thank you Ned. Here are some pics of machinemophorn 1

mophorn 3

Does anything light up when you power on the machine:

  1. Control panel?
  2. Grn Led down on the LPS?

I assume you have verified the wall socket by plugging something else into it?

Do you have a DVM and are you comfortable using it??

Thanks Don. No…the control panel nor the light comes on. Normally it would home also when powered on. Have power…Don’t have a DVM nor not sure how to use one.
Appreciate your response

Ok, I suggest the following.

  1. Pull out the fuse that is in the input plug. If it is glass inspect it. There should be a fine wire inside and if you look carefully you can see if it is burned open.
    If it’s not glass we will have to use a different approach.

Are the pictures above taken when this problem exists, I notice the temp meter is lit up?

Do you have one of these? https://amzn.to/3c5d7JT

I have that temp meter also on my machine and it runs on a coin battery.

also I could not get the fuse out so I unhooked the wires…marked them with felt pen on tape…but marks came off I know which wire goes on top but now am concerned that I will get the two on the left side wrong…another senior moment

Ah! Makes sense

Below is a sketch I made showing the back and front of that socket.
I do not know what the wire colors on your machine are but typically:

G (Ground) = green
L (Line) = black
N (Neutral) = white

Note: if your wire colors are different let us know, with pictures!

1. Did you manage to get the fuse out and check it??

If you cannot get the fuse out by hand you can try to thread a string in and around the fuse and pull it out.
Sometimes a needle nose pliers will also work.


The datasheet for reference:
http://www.qualtekusa.com/images/AC_Receptacles/pdfs/719w0002.pdf

1 Like

@laserred K40’s are notoriously unreliable. It may be worth your time and $ to get a tool that will enable you to read the circuits in the K40. It’s hard to troubleshoot a machine if you cannot read voltage.

Alternately you can buy an inexpensive DVM off amazon.

Here is one of many videos avail on YouTube on how to use one.

1 Like

Ahh, thanks for that. I was wondering how that plug was wired internally.

Thank you Don. The fuse looks ok. Both wires on the left side are blue on my unit. The seller stated that these can be connected arbitrarily and to check the power supply again.

I really appreciate your help and this forum
cheers

So we still have not solved your problem??
We can check if there is power going to the LPS but you have no way to measure that??

Woohoo…it is working…thank you Don! All I did was swap the fuse (which looked ok) for the extra fuse that came with the machine

I am so relieved

2 Likes

Glad to that worked but the question now is … why did the fuse blow?

If the fuse failed but didn’t look blown, it’s possible the fuse didn’t blow from overload, but instead itself was defective. Unusual but not unheard of.