Lazer engraving machine

Hi I need help please. I have a 3040c laser engraving machine and it keeps on saying disconnected on my pc

Commonly, replacing the USB cable with a higher quality one is the answer.

Hi, I have changed the cable. I have tried everything. It was working perfectly and when I switched it on again it says the engraving machine is disconnected.

Well, if you have literally tried everything than clearly there’s nothing else that can be done! But let’s assume that there’s something else… :smiley:

In order to make it possible for others here (I’m not particularly the expert, I just happened to see your post first) to help you, you could list all the things you tried when you tried “everything” because no one here will be able to read your mind and guess what those things are. :frowning:

Also, that name is pretty generic. It pretty much means that it has a 30cm x 40cm engraving area. I see both CO2 and LED lasers marketed with names like that. Please provide clear information about the actual unit you have, in order to enable others with more expertise than me to help you.

1 Like

I don’t know where to check. Only had the machine a few months. It is actually my daughter’s.

I cleaned all the mirrors, aligned them. Cleaned the wires and ensured they are all connect and tighted. Tested the lazer which is sparking correctly. Changed USB ports. Changed the cable twice.

Ok, it looks about like this listing, a Suna. I was hoping to find what controller it uses, but no such luck.

I’ll let the experts here suggest things; I’m just thinking through things that others have resolved over the past few years here. But lost connection on the attached PC is going to be a port on the PC (unlikely since you tried multiple ports), bad USB cable (still possible, we’ve had people report bad connections with multiple cables until they bought something particularly high quality, but also unlikely since it was previously working), a bad ground connection somewhere including your house wiring, the connection from the USB port on the case to the controller, or a problem with the controller. At least, that’s all that I can think of…

A picture of your controller and its wiring would help.

Not sure what the controller is lol.

Any chance you can get camera down near the circuit card??

I am wondering if you lost a DC supply.

Has this machine been modified. Looks like 2 laser supplies but one is only used as DC source ???

I am not sure we bought it from an old lady. Hope this is it.

M2 Nano Controller.
Post a picture of the control panel pls.

Do you have a DVM and know how to use it?

Not sure what DVM is. I hardly know these things sorry

DVM digital volt meter

Any voltmeter will do, however these are low cost and very accurate.


Righto. Now i have a dvm… what do i do. Where do i test first?