Layer thickness problem

Hello everyone,

I have a problem with all my printing. On layer 2/3 and sometimes 4, my head doesn’t go up enough to print the next layer. It even goes down sometimes, so I print 2 layers on top of each other. All in all, it’s ugly…

I’m under the latest smoothieware firmware with MKS Sbase 1.3. My Z engine is a nema 24 with independent stepper, so it’s not an effort problem.
I changed my slicer, with cura or Simpilify 3d. Direct printing or web printing, but nothing helps.

I have the autobed set up with a Bltouch. I suspect it’s the dynamic Z-correction which goes wrong.

Any ideas? Or better yet, do you have a solution?

Thanks in advance and good containment! :grin:


And it never ever happens on layers above that? If so it sounds very much to be a mechanical issue.

I can’t imagine something firmware related that would do this.

( oh also just in case you’re not aware: if you already know please ignore this, thanks )


Hello @Arthur_Wolf, thanks to your answer.

All my layer above are perfect.
I change my motor by a nema 17, and I’ve the same problem.

If its not the soft, its the hardware of the card…
It sounds to be strange !

I have helped thousands of people, Out of the people who say “it has to be the card, it can’t be mechanical”, I’d say a good 90% end up being mechanical. That’s just factual experience. Please check your hardware and try things you can do to change the hardware situation.

I really don’t see what on the card could cause this, it makes no sense for this to be the card. Please try lower current and higher current, and see if you can get that to make the situation better or worse, then tell us the results.

1 Like

Ok thank you to your answer, i will investigate with your advices

Have a good day :slight_smile:

A failure only at a specific level is basically universally hardware. It would be extremely unlikely to be motors, either. Binding due to a (probably tiny) physical irregularity is the classic cause for this kind of problem.

1 Like

Hello everybody,

I did a lot of test (change motor, motor controller, steps, current) and my problems seem to be solved when i disable this line:
#leveling-strategy.rectangular-grid.height_limit 1 # no compensation to apply after this point (optional)

What value do you have on your config ? Do you use this option ?
Thank you :slight_smile: