K40 - Offsets in Vector Engravings

Hey guys,
I have some issues with my K40 with Mini Gerbil Board and using LaserWeb when I do some laser engravings.

There are some kinds of “offsets” in the engravings. I don’t think the speed is too fast (10mm/s).
These offsets are always at the same position, so I don’t think there is a problem with the belts.
Raster Engraving and Vector Cutting works fine! It is only with vector engraving (LASER FILL PATH). I set Line Distance with different values, but without a good result.
Could there be wrong settings with my steps in mm, acceleration, max rate or anything else? If yes, how can I fix it in LaserWeb?
Or do I have some issues with my svg files?! I use illustrator to create and edit vector files. So I use 72ppi in laserweb, correct??

But I don’t know how to fix it. I think there is a communication problem with laserWeb and the Mini Gerbil Board or some wrong settings with the steppers or anything else, but I don’t know what it could be.

I also attached my settings in a screenshot. CAN YOU HELP ME GUYS?!

Thanks for your work!!!
And sorry, but I am a nearly noob in this “laser-game” :slight_smile:

This is my Engraving … The Picture should look as like this …
… here the same. These Offsets are always at the same position!

Bildschirmfoto 2020-07-27 um 08.36.32|212x500 Bildschirmfoto 2020-07-27 um 08.36.53

Have you tried really simple SVGs with no lines that cross, like just a square, circle, thin rectangle?

Could you upload the SVGs associated with these engravings?

yes, I tried. With a speed of 10mm/s it is working I think, but if i go faster, the shaping is getting “etchy” … I think my stepper rate is to high so I get lost some steps.

I read that $100 has to be about 157 steps/mm. Have to check what my values are. I think I have some wrong settings anywhere.

Here is the SVG.
But I think the file isn’t the problem, because I have similar issues with other SVGs

There were more obvious artifacts in “Pascha” and the outline engraving showed crossing lines. I’m not an expert here, just suggesting that those who are might find it easier to help with all the information you can provide. :slight_smile:

yes, the problem with crossing lines is solved. Was my mistake in illustrator.

But also the fixed vector file has similar offsets :frowning:

To be clear, for “I tried” — are you saying you see the same gaps in simple geometric shapes with speeds above 10mm/s?

Have you adjusted belt tension?

with e.g. 100mm/s I cant write a round cirle.

Yes, I checked the belts.
I suspect a problem with settings, because the offsets are always at the same position! If it was a belt issue, there would be the issues more random.

If I am at home, I will connect my laser and post mY $$-Values

I asked about belts because backlash can show at places that are characteristic of the shape of the image regardless of the location of the image. Just trying to cover all the bases to help others with more experience than me have more information to be able to help. :slight_smile:

I hope I tightened the belts right :slight_smile:I think they aren’t too tight but even too loose :slight_smile:But I am a totally beginner with the K40.

But I think if it were the belts, raster engraving wouldn’t work aswel.

I only have problems with vectors

The fact that your artifacts are all on one axis even though you are doing vector engrave I think really could point to a physical origin to your problem.

Belts that are too loose can definitely cause backlash in any machine, and raster engraving would be fine as long as it’s unidirectional. If only your Y belt is too loose, bidirectional raster engraving would be fine. You mention that vector cut works fine, but also that vector engrave below 10mm/s works fine, and probably you aren’t doing vector cuts at 100mm/s.

You could also have some other similar mechanical problem, like insufficient preload on a guide wheel.

I will post a picture later from a circle cut with about 100mm/s when I am at home and can turn the laser on :slight_smile:

Hope I haven’t a physical problem :frowning:

How can be the insufficient preload can be fixed?

Fixing insufficient preload is where we come crashing out of the theoretical and land solidly in the practical! I don’t own a K40, so I don’t know details of its mechanism.

(I had a 3D printer with a similar problem, where — among many other problems — there was insufficient preload on guide wheels and no mechanism for setting preload. I threw away the entire X/Y axis and made my own design. That doesn’t help me help you at all, though!)