I am having trouble with the auto-level widget,

I am having trouble with the auto-level widget, even though I used without this problem. The specific problem is that after making the first probe (in “run” mode, not “run test probe” mode), the cnc stops upon making contact, rather than retracting, moving to the second probe location, and re-lowering to make the next contact. The touch plate widget works fine – it lowers until making contact, then immediately retracts. I have some ideas that may help diagnose / solve the problem, but if anyone has any suggestions, they would be greatly appreciated.



Is it /grbl or /tinyg workspace?

I will post screenshots tonight. This is a tinyG setup. As mentioned, the widget was working fine for me, the only trouble I had was that it would occasionally fail to sense contact and keep pushing. I intended to, someday, improve the sensing mechanism but in the meantime, I stopped using auto leveling.

Then last weekend I needed to cut a larger board (which is inherently less level) and decided to try again. That is when I first experienced my current problem – that after making first contact, the spindle doesn’t retract – there is no more movement at all (but the board is not frozen, I can give it other commands without a reset or reboot). Although nothing had changed in my configuration, I tried to diagnose the problem. Importantly, the touch-plate widget was working fine (and I didn’t actually use a touch-plate – I used the same setup was with auto level: one lead alligator clipped to the mill (bit), the other soldered to the top of the copperclad). I checked (and reversed) the polarity of the sensor wiring with no effect (I thought perhaps that the spindle was picking up and forwarding noise.

At that point, I decided to try to address my original auto-level problem (the occasional failure to detect contact). So, I set up a relay to be triggered (at 9v – way better, I think, than the tinyG’s 3.3v) by the spindle/copperclad contact, with the relay then closing the tinyG sensor circuit. Anyway, that didn’t solve my autolevel widget problem, but the touchplate widget still works fine. My thought at this point is that I must have some setting on the auto-level widget wrong since the hardware seems to be fine (as evidenced by success with the touch-plate widget).

Thanks - Rick

Do you get a probe error in your serial port console? You’ll have to turn the funnel off to see it. Versions of everything helps too, which is why the screenshot helps, i.e. what firmware version you’re on.

I believe the last entry in the serial port console was moving to x,y. I was surprised not to see anything about changing z, etc. I will get screen shots of everything (tonight if at all possible).

What do you think of my 9v probe set up? It seems to me like it should help, and if need be, I can move the relay much closer to the tinyG to eliminate the signal line’s exposure to noise. Since the relay has an LED to show when it is triggered, for now I like keeping it on the face of the spindle. (right now, it is taped in place, but I intend to upgrade to velcro once it works).

Thanks for your interest and advice. -Rick

I like the higher voltage for probing as I think I need that too for my smaller end mills to effectively probe, but I worry a relay has too much lag because you need a very quick response rate when the end mill touches to not damage it.

I was concerned about the relay being fast enough. its response time is supposed to be 5ms. By my math (which doesn’t sound right, but I have doubled checked and can’t find an error), if the end mill is traveling at 5 mm/min , and given the relay’s response spec of <10 ms, it will travel it will travel less than 1 micron while the relay is reacting. But, if it turns out not to be fast enough, I will replace the relay with a transistor.

I am embarrassed (but delighted) to report that the widget is now working correctly for me. I tried the “Run Test Probe”, which did not work (the probe did not retract after making contact), but then tried regular run, as I had before, and this time it works fine. The only thing I did differently was to try the test probe first, although I suspect I had tried that previously. Also, my tinyG was rebooted.

Sorry for the false alarm, but I did try for a few hours last night.

Anyway, it appears that my board is highly warped. I will auto-level the whole thing, then try cutting.

Regards, Rick

No idea whether this is a similar issue to the identical problem found in grbl. I traced it to a JavaScript bug that triggered when showing the matrix after each test. It was sometimes encountering a member of the lyr object that had no property called material. And at that point just died. I fixed it with an overload in my clone of grbl workspace (not the widget).

If the tinyg workspace manages the matrix overlay in the same way this could be what you are seeing.

For me it was arbitrary. Or at least I discerned no pattern. But the problem disappeared when this small function was fixed.

@Justin_Adie that’s an interesting theory and could be a cause.

Update: The problem of the auto-level process halting after lowering the probe has resurfaced, but I have isolated it somewhat: It seems that if I deactivate the eagle board import widget, then the auto level widget will then run fine. What am I doing wrong?

Are you getting any javascript console errors?

No. I will replicate the problem and take a screen shot. (Right now, I am cutting a board that is supposed to take 8hrs – I slowed down the rates hoping to stop breaking the 0.3 mm mills I am trying to use.)

I am not sure it is related, but during some of my auto levelings, the probe will pause/stall in the down position for up to 10 seconds. And that delay time seems to grown during the progression through the probe points.

In some circumstances, I have been able to complete an auto level even with the eagle widget open. So, the variable seems to be more specific than just eagle widget open – it seems to also depend on my board, suggesting that Justin’s theory is correct.

Here are a series of screenshots:

First, demonstrate the problem, beginning just before I push play on Auto-Level. The EagleBrd widget can be seen open (but collapsed), and the display area is shoing gCode for my board
missing/deleted image from Google+

I couldn’t figure out how to show more of the serial port at this stage, but do below. This next picture shows after auto-level has started but hung after completing the first probe.
missing/deleted image from Google+

The shot above shows the most recent serial data, none of which looks like an error to me.

For comparison, this shows auto-level not getting hung, the only difference is that I closed (de-selected) the EagleBrd widget before starting the autolevel probe:
missing/deleted image from Google+

And here is a screen shot after auto level has successfully completed several probes:

missing/deleted image from Google+

I was able to get auto level to work with this board without closing the EagleBrd widget, but only after jogging around a bunch, drilling a couple reference holes, resetting zero’s etc., so I have no idea which of those activities made it possible to successfully run the auto-level widget without first closing the EagleBrd widget.