Hi all. I'm trying to give GRBL-LPC a try since I'm hearing good things.

Hi all. I’m trying to give GRBL-LPC a try since I’m hearing good things. I keep getting the “No supported firmware detected. Closing port COM6” message from Laserweb v.4.0.988
I’m trying to use the firmware.bin from: https://github.com/cprezzi/grbl-LPC/releases

I’m running windows 7, so I had to install drivers manually. I found the driver in the GRBL-LPC source code and now my computer recognizes the Smoothieboard and assigns it to a COM port while on the GRBL-LPC firmware. Laserweb sees the COM port, but I get the error every time I try to connect.

I’ve had this all working with smoothieboard firmware, but I wanted to try GRBL-LPC. Anyone have an idea what I’m doing wrong? Is there a driver setting that needs to be tweaked perhaps?

I’m using a 4x smoothieboard with a custom build co2 laser.

Try connecting to it with a terminal program such as PuTTY

Thanks for the suggestion. I can connect to it with PuTTY. I’m able to read the settings etc. Looks fine there. Any idea why Laserweb is not happy?

Odd. @cprezzi ?

I had that same problem with one particular Win7 Desktop Dell PC. No matter what I did, I couldn’t get laserweb to connect to grbl-lpc. It worked fine previously with smoothieboard and will connect via serial terminal. Had no problem with two other Win7 laptops to connect to grbl-lpc. I even tried another USB card. Replaced USB drivers etc. It wasn’t until I upgraded to win10 on that desktop that it finally worked!!! Microsoft :frowning:

Okay, Thanks for chiming in. I’m updating an old computer I’ve got lying around. I’m going to try it there. I was thinking of using it as a dedicated machine for the laser cutter anyway… I’ll let you know if I figure out another way to fix it.

Well, I’m pulling my hair out a bit now. Fresh Windows 10 install on a different computer. Same problem. Windows recognized the board right away and assigned it to COM3. PuTTY connects just fine. It lets me configure settings and all. Laserweb still says “No supported firmware” and disconnects after a few seconds. I’ve reflashed firmware several times now.

I’d think there was a problem with my smoothieboard if it wasn’t for the fact that PuTTY seems okay with it.

When I initially connect with PuTTY, it returns:

Grbl 1.1f [’$’ for help]
[MSG: ‘$H’ | ‘$X’ to unlock]

Grbl 1.1f [’$’ for help]
[MSG: ‘$H’ | ‘$X’ to unlock]

Not sure if it’s supposed to repeat like that.

I have one more laptop I can try to connect with, otherwise I may need to stick with the regular smoothieboard firmware.

If anyone has any ideas how I could troubleshoot this, please let me know!

Thanks for the help! This community has been immensely helpful!

You could try to enable board reset on connect by adding a “.env” file to the installation directory with the line “RESET_ON_CONNECT=1” in it.

Not entirely sure I understood your instructions, Claudio. I created a new text document in “user>AppData>Local>Programs>lw.comm-server”. I then added a line “RESET_ON_CONNECT=1” without the quotation marks, saved it as env.txt. Then I changed the file extension so I had the file env.env. Sadly, this did not appear to accomplish anything.

Thanks for taking the time to read my post and offer a suggestion.

I have tried connecting from 3 different computers now. All with the same result.

@Sam_Bakker You did it nearly perfect, just the file needs to be named “.env” without something in front of the dot.
Unfortunatly this is not so easy to do on Windows 10, therefore I have added this file to our documentation page @ http://cncpro.co/index.php/65-documentation/initial-configuration/firmware/grbl-lpc-1-1e (the link “.env file”)

Once you saved the file in the installation folder, you can edit it with notepad.

You have to use the command line on Windows:

ren env.env .env

@Todd_Fleming I know but thought it’s easyer for a normal user to just download the file :wink:

Thanks for the help! Unfortunately, this hasn’t fixed my problem :frowning:

Not sure why my board is behaving differently than so many others…

Anyway, I really appreciate you guys trying to help me!

@Sam_Bakker There is something additional you can try:

If your board needs a bit longer than usual to respond at connect, you can add the line “GRBL_WAIT_TIME=5” to the .env file to increase the timeout to 5s (instead of 0.5-1s).

I gave that a try, and still no change. I’m still getting the same no supported firmware message…
PuTTY does seem to connect instantly when I connect there.

Hm, that’s very odd.

I’m not sure that the .env file is even used. To prove that, you can add the line “LOG_LEVEL=3” to the .env file.

This should create a logfil.txt in the installation folder after starting LW4.

If there is no logfile created, then the .env file is not correctly detected.

I think you’re right. I do not get a logfil.txt file after adding this line to my .env file.

The file is in:
After changing the .env file I open LaserWeb.exe from that same folder.

The installation path on my Windows 10 system is “C:\Users\username\AppData\Local\Programs\lw.comm-server”.
Did you just shorten it in your post or is it realy different on your system?

What OS are you using?