Google authentication working again

(Michael K Johnson) #1

For much of the weekend, Google authentication was failing for new users. I believe this problem has been resolved.

If you encountered this problem, please try again. You should not need to send an authentication email. If you still can’t log in, please send email to admin@makerforums.info so that we can investigate.

After you log in using google authentication for the first time, please go to user preferences and set your correct email address. You may see an email address that ends in @gplus.invalid — that’s because Google+ didn’t provide your email addresses for the data import that we did for about 40,000 posts so far, and Discourse requires an email, so we had to “get creative” and some of the consequences have required additional creativity.

Thanks for your patience while we help preserve our path forward from Google+!

1 Like
(Michael K Johnson) pinned globally #2
(Phil Duby) #3

Wonder what changed? I have been logging in here with google. In fact I currently am logged in with google.

(Michael K Johnson) #4

Yeah, those who already logged in are safe, I think. The system was sending email to the invalid addresses I made up for imported users and mailgun didn’t like that (I used the RFC-reserved .invalid domain so it should have thrown them away, but I’m not in control of that). I therefore disabled the users, thinking that the google authentication process would re-write their email address with the email address provided by google auth and send it. But it doesn’t do that, so the system tries to email the invalid address, which doesn’t let them validate!

I am also concerned that I might have invalidated some existing users unintentionally.

I’m now exploring other options, trying to get back to where we were except without making mailgun unhappy again.

Update: I think I found a solution. Let’s try it!

(Phil Duby) #5

Ah! That is (very likely) why my preferences information here still shows the connect button, for google. Instead of the username that shows beside the github account.

(Michael K Johnson) #6

@Phil_Duby I checked, and yes that’s a likely case. Can you try the “connect” button now? I’m curious whether it works now.

(Phil Duby) #7

Clicking the connect button got the request for the google account to use, did that, automatic refresh of preferences page, no error, still shows connect button. Logged out, and back in (with google again), repeat, same result.

Not working, unless it is waiting for a confirmation, that I have not received the email for (yet).

(Michael K Johnson) #8

At least you can log in with Google. I’m flying blind here, because I don’t actually know what it is supposed to do in this case. :confused:

(Phil Duby) #9

Sounds like you need a separate google account, that does a post to google+ (community), export, import, then try to login with google account. I assume that what you are currently using started with a full account here, independent of google, and that is interfering with testing.

If you can completely separate the owner/admin account you use here from the account you use to view/post content, there should be a better change. But the existing history could make that difficult. A separate account is needed, that does not have any of that history, but does exist in the imported g+ data.

(Michael K Johnson) #10

Yes, in theory that’s what I should do. In practice, I’m going to say that good enough is good enough and spend more time with my family, who have kind of missed me the past month during the mad scramble to rescue us from Google’s short attention span. :slight_smile:

2 Likes
(anon57870006) #11

I have right now erased my G+ account as a reaction for them muting several of my posts.
Now I have logged on with gmail account.
Do you recommend creating local account? Would it map to my posts?

(Michael K Johnson) #12

@anon57870006 If you create a new account no it won’t map, and please don’t make more work for me trying to map accounts together. I think you can set up password login for this existing account if you haven’t already done so by sending yourself a reset password link from your profile.

Deleting your G+ account hardly hurts Google, though it will mean you’ve just removed yourself from any further communities I import. :confused:

(anon57870006) #13

I’ve been no member of any other communities :stuck_out_tongue:
I dear your work so do not respond to comments here :wink:
The reset password field I could not find. No problem.

1 Like