FreeCad: innacurate 1:1 printing

I started to move from Fusion 360 since I do not use it that much and it is not free.
I am learning FreeCad.
Everything was going fine until I tried to print 1:1 scale, it was off about 1/16 over 3".
I use 1:1 printouts as templates for fabbing a one-of-a-kind part.
I have tried everything to get rid of this error.

One thing that worked is to export the file as a .svg and then print it. That approach is dead on.

It seems that if FreeCad can export an SVG of a model correctly it should be able to print it accurately.

I wonder if I have one of the 100’s settings in the wrong state ???

Any FreeCad users that are printing 1:1 successfully.

I print from FreeCAD often and only had a problem when “shrink to fit” got enabled in the general print settings accidentally. I’ve used spray adhesive to attach prints to parts, which I think is the same kind of thing you are talking about?

Do you print directly or create a pdf and print?
What print menu item do you use?

You know… I think I almost always Export PDF from the file menu and then print the PDF, because I think of the PDF as a project artifact that I want to version separately. Sorry, it’s such second nature that I forgot that I do it! :flushed:

But I occasionally print directly from the TechDraw drawing and I think that scales correctly for me. I do use Linux, and Linux and Mac use the same print system but Windows is different, so it’s possible that the print settings are different on Windows somewhere that I don’t know. At least on Linux and Mac with most modern printers, the PDF is basically just sent on to the printer fairly directly.


I think I tried techdraw, & from Sketcher both directly and via PDF.
The error is subtle but there.

Strangely an SVG exported from techdraw prints accurately. This tells me that FreeCad has the drawing stored accurately. Something happens during making the PDF or print.

Perhaps I should send you one that does not work and see if it works in your setup?

I’d be happy to do that.

I’ve never, as far as I recall, printed from sketcher. Probably only ever TechDraw.

Go ahead and send me pdf, svg, and FCStd files and I can compare.

I have this problem from Fedora FreeCAD. I export a tech draw page to PDF, open the PDF, make sure that scale is 100% and that shrink to fit is off, and then it’s consistently a bit too small.

When I really needed it to be 1:1 I measured the print and scaled it to something greater than 100%. Super annoying.

I’m using a Brother monochrome laser printer.

@donkjr and I exchanged emails today so I could look at the exact files, and the scaling problem was using the default A4 template, which then gets scaled when printing on US Letter paper.

I haven’t had this problem because I use a template with US Letter dimensions — practically always a blank template with no info block because I care more about drawing space.

Screenshot from 2023-08-13 08-27-23

Screenshot from 2023-08-13 08-28-06

I’m using Fedora with the official builds of FreeCAD as Appimage files, printing on an HP Laserjet. I’ve used spray adhesive to attach cutouts as guides and they have been dimensionally accurate.


I seem to remember that I checked the template size but I’ll take another run at it when I have a moment to confirm. I’ve meant to make a custom TechDraw template for my projects so this might be a good excuse to do so. :smiley_cat:

If your effective printing area for your particular printer is smaller than the content in the template (the borders exceed that printable are) and you have shrink to fit, you will get the same result.

I understand. My intention is to make a template that is smaller than US letter.

To be clearer… I only meant that the default US Letter template border might not fit on your printer and might have been the source of scaling issues even if you chose the right template, if you have a printer with a particularly large unprintable area. (I was not satisfied with my Brother laser printer for a host of reasons, and have only a faint memory that it might have had a larger than usual non-printable area.) But yeah, making a smaller template should do the trick in that case. :smiling_face:

1 Like

Oh, interesting. I think my first test should be to make a 5"x5" template (so, clearly smaller than the printable area) and confirm that it is correctly printed.

1 Like

1/16th over 3" is 1/48th off.

96dpi is a multiple of 48. I wonder if the dpi on export/import is the issue? (Maybe its double the 1/96 off because of centering or ???)

Just a thought!

PDFs dimension (virtually) physically, not in DPI.

This is a relatively common problem, I think, for Americans who use the default A4 templates, which are longer and narrower than US Letter paper, when their print settings (or driver not offering print settings) shrink the output proportionally by the difference in the constraining dimension (width).