Fibre laser connection issue, ezcad virus

Hi, bizarre story/issue that I hope this community can help me with! I bought a fibre laser from China a few months ago and it’s been working fine. The issue is that the version of ezcad supplied had a virus which I was able to contain but finally my ant-virus quarantined the exe file. The supplier of the machine sent through a new version of the ezcad software but I can’t get it to connect (cant find dongle). I’ve tried numerous other versions and other packages and no luck. Also tried another machine with the same results. I’ve now released the corrupt software from the anti-virus to check that is still works, it does!

I’m wondering if the earlier version of ezcad was configured to a specific board and that the new version to a different board that the supplier now uses. Is that how it works? If you have any thoughts or suggestions please let me know. Thanks in advance, Mark

By the way the supplier is saying that the new software does not work on Win 10 Pro, where as the older one does, make sense of that… thanks again

I suggest two other routes before trying to get dodgy, dongle-limited, virus-infested software working.

  • Meerk40t has experimental support for some galvo and gantry fibre lasers and is free, open source software. It has grown beyond the “k40” in its name. :smiling_face:
  • Lightburn has galvo support and a zero-cost 30-day trial so you could see whether it works on your system.

Thank you so much for your reply! I have tried lightburn but will do so again, not heard of Meerk40t so thanks for the suggestion. Hope to try in next day or so


I would see if there is an export configuration or export device setup options which could then be loaded into the newer version. The export option might pickup a setting not picked up by your manual configuration. Otherwise, what Michael said.

1 Like

Hey Doug, I’ve tried looking for a config file but nothing that seems to get to the level required. Will keep at it. Thanks for the reply

Thanks again for your advice, I’ve gone with the Lightburn option and have managed to get it to work with minimum fuss. I did go through a tutorial to get both Lightburn and ezcad drivers working but no joy. At least lightburn is working for me a looks to be a better package so thanks again


You won’t be sorry with Lightburn…

Good luck