Engraving Dots and Spots

So, new Omtech K40+ with a new 40w laser tube installed after the original got damaged in shipping. After getting the mirrors aligned, I’m now back to cutting acrylic like butter.

Unfortunately, a new problem popped up. I’m getting small burn spots on my engravings. I’ve searched these forum posts and I saw that some others have had the same issue but I didn’t see anything that fixed it. Perhaps there is no fix.

A work around seems to be masking the acrylic with blue painters tape. Although, I’ll have to bump the engraving burn percentage up a little more or slow down the speed.

I attached a couple sample pieces out of some scrap acrylic. The first picture is of the burn dots (290mm/min, 25% power). The second picture was masked with tape…no dots…but it didn’t burn as deep (290mm/min, 25% power).

I haven’t contacted Omtech support yet but will later today.

As I recall we troubleshot this problem some time ago on this forum with no resolution.
It seems this problem exists but no one has found a solution :grimacing:

Does this only occur on this job?

My recollection of that thread was that it was specific to Ruida controllers, but this is with a gcode-speaking controller of some kind. @jkwilborn I think you were one of those who participated, either here, on the lightburn forum, or both?

This came up in the Lightburn forum, using a scope, it was confirmed to be an lps issue.

It lases when the signals tell it not to … the evidence is clear. I also have a Ruida and have never had mine do this.

If you’re driving this using the L input, I can’t imagine there is much difference in if it’s grbl, dsp or a telegraph key.

I’d try and weasel out another lps from OMTech, I don’t think there’s much doubt it’s the issue :wink:


1 Like

What are the chances that I’ll replace the lps and the problem still persists? I’m not sure what Omtech uses but is there a higher quality aftermarket lps that I should try instead?

Since we do not know what is causing these random firings a new supply may not solve the problem. If Omtec is willing to send a new one why not try it?

I do not believe that the supply itself is creating random firings. My intuition is that there is some kind of external noise creating these dots. The tests I have seen rule out the controller but that does not mean the LPS alone is creating these fireings.

If the controller signals into the device are correct, but the output isn’t, what would you suggest to increase your confidence that this device is failing?

It would be nice to put this issue to bed, once and for all … any suggestions would be great…


Omtech support was questioning if my ground was separately connected. It is not because I’m using a three prong plug instead. I would think that is sufficient.

The other thing that they wanted me to check is to disconnect the black and yellow terminal from the board and do an engraving to see if the dots go away. I’ll try that this evening and see what happens.

And speaking of “noise” I’m using the USB cable that was sent with the machine. It has a single ferrite choke on it. I think I have some ferrite chokes somewhere. I could add another on the other end of the line. I also thought about disconnecting that USBA to USBC pigtail in the picture and just plugging into the USBC line to see if that would clear up some noise.

My first idea is nothing wrong with your machine.

I am more thinking the dot could be made by melted acrilic droplets spreading after burning leaving the marks.
as you engraved it’s stay on top, but if you cut it fall trough.
masking tape look a good idea, try to find something thinner to avoid perturbing the work.

Alternatively I would also try 2 passes at half the power.

With these controllers, you’d have to have a scope to determine the signals to the lps. So @donkjr could be correct as something else being the root cause here…

Do you know what lines these are?

The less stuff in the line the better… Connectors are inherently noisy as there is usually a change in impedance…

Good luck :wink:


Still wondering if it does this on all jobs.

I don’t think that the problem is noise at the USB signals as to fire it would have to be a complex noise that produces an actual set of commands.

Usually, these kinds of noises are due to grounding loops in the supply or the cabling. It is often introduced through the DC supply.

The acrylic droplet is an interesting out-of-the-box idea!
Tell us more about the tape masking. Do you mask the entire area and then print through it?
Were there any random dots on the tape you removed?

It would be nice to be able to see (sync on) the dot fire at the LPS output and then trace backward to see if there is any control causing it. Don’t know how to do that since the dots are random.

In the traces I looked at I was not sure that*:

  • The time scale would show a fast control pulse.
  • How do you tell a random dot from any other dot?

In a control stream this complex it is easy to be fooled nothing it going on.

*I may not understand the test setup and pattern …

I would say burns on the tape.

the idea behind the 2 passes at half power, is to burn less material at once, are the dots smaller if any (less reaction) are the projection closer to the last engraved zone. (less force)

@ jkwilborn
I have a picture of the power supply but I’m not zoomed out so I cannot see for sure where the black and yellow cables are connected. Based on the below picture it looks like it’s the last two at the bottom. Not sure what they are for.

@ donkjr
Yes, it does this on ALL engraving jobs.

Normally, when I engrave clear acrylic, it has the typical brown paper masking on it to protect from scratches. I always engrave with that masking on but in this case I was using scrap acrylic with the masking removed. To add masking, say if I were to engrave wood, I add a single layer of blue painters tape (3M) large enough to cover the engraving. Typically, I have to increase the power and maybe slow the speed down a bit to burn through the tape adequately. This also eliminates scorch marks.

I did not look but assumed that I was getting laser dots on the tape but they were not strong enough to burn through, protecting the acrylic underneath. I’d rather not add tape to acrylics but it’s the only workaround I have at the moment.

I have another ebay K40 with an M2 Nano board. I used k40 Whisperer and never had issues with artifacts on engravings. That machine still works great, by the way. It’s only the gantry that I don’t like. Not as buttery smooth as this Omtech K40+.

@ StephaneBUISSON
2 passes might work. That didn’t occur to me. Might be better than tape. Sure, it takes longer to engrave but that’s not an issue for me.

All engravings, what about vector graphics and cutting?

Well, all of my projects start with vector graphics. I never use raster images. 98% of my artwork gets created in Inkscape and then imported into Lightburn (or K40 Whisperer before this) for cutting, engraving, or light vector marking.

On the engineering side, I make a lot of acrylic templates for our Keyence measurement system at work. They start life as a 3D CAD model that gets exported as a dxf and then brought into Lightburn for cutting and engraving.

The only issue I have with the whole machine is engraving with the dots. You asked about the blue tape…if I got dots on it. Yes, but the tape is protecting the acrylic. See images below.

Here I tried blue tape with 3 passes at 15% power at 290mm/s. It works rather well and is my workaround at the moment.

If I want to plug a ground wire into the ground lug on the back of the machine, do I really need to run that outside and attach it to a copper rod in the ground? Can I connect it to something else more convenient temporarily? I think Omtech is wanting me to do this.

I’m guessing from the “HALL PASS” that you are in the US. By code, the ground connection in your outlet must be electrically connected to a solid and effective earth ground, typically a copper rod in the ground, or sometimes a copper pipe (when the house is supplied by a copper water pipe that is located in reasonable proximity to the electrical service).

So if you have plugged into a grounded outlet in a building built in the last 50 years (grounded outlets became required everywhere in 1971, and were first required outside laundry facilities in 1956 and extended to kitchens in 1959, and as of 1962 all outlets needed to have a ground wire to them regardless of location), you have already done what Omtech just asked, just by plugging it in. [Edit:] Also, every grounded outlet must by code be actually grounded, so if you are plugging it in to a grounded outlet it must by code be grounded, regardless of when the building was constructed.¹

It is not a reasonable request to ask you to do major electrical work without a rational diagnosis that your electrical system is not up to code.

Do you have a three-prong outlet tester? They have a display for “open ground” which would indicate a problem.

If not, I prefer the ~$13 kind that can also test whether an outlet is behind a GFCI. You can get them at any home improvement store.




¹ Let us be grounded the History of the grounded receptacles in residential homes Wenatchee Home Inspections | NCW Home Inspections, LLC

1 Like

Mains grounding… what @mcdanlj said.
If there is a grounding problem causing this I would expect it to be related to the DC power.

My tape questions are directed at getting hints as to the source of the dots.

I asked about dots on the tape in connection with @StephaneBUISSON idea about molten particles. Re-thinking it I realize that it’s not a helpful observation :thinking:.

I notice that the dots are only around the areas where the text is imaged not the lines. Is this a correct observation?

1 Like

Yes. Northern Indiana to be exact. My house was built in the early 80’s. I’m assuming all of my electrical outlets are properly grounded but I’ll order the Klein recept. tester and check.

That’s about right. Any line that is cut or lightly marked…no dots. All engravings have the dots.

In theory the inspector should have tested that. In practice occasionally they are imperfect. (In my 2003 house I found an outlet where they hadn’t tightened the screws!)

But that tester will give you the ability to say “I have verified that the outlet is properly grounded” in any case. :grin: