Chilipepper serial json for Raspberry PI4

tryin to load serial json for chilipepper to PI4 board.
has anyone every tried this? Followed the instructions on Github.
Came back w/ error from pi prompt: Did not like the first wget come.
Thanks in advance. Trying to use pi4 as controller for GRBL cnc.

Did you grab the binary? What version? Hopefully from GitHub release page.

I just updated the releases page with a better wget statement:

wget https://github.com/chilipeppr/serial-port-json-server/releases/download/v1.96/serial-port-json-server-1.96_linux_arm.tar.gz

I just did this with the new link and it works great. Unfortunately some of the other lines in the instructions have typos.

To un zip the gz file the instruction says to use gzid, which of course should be gzip. Then the untar line references the original file with the .gz on the end, which of course doesn’t exist any more since it was unzipped. Use the file name without the .gz.

After that it installs properly and works well.

Chilipeppr on the rpi 4 works very well, now I just have to find a fairly sealed fanless aluminum case for the 4.

I’m running using chromium which is the default browser in the new raspbian. The response seems almost as good as my big xeon system, I am very impressed. This is the 2 gig of memory version.

John S.

Hmm. Good catch again. My auto release script apparently has typos in it! I just updated. Thanks for the feedback.

Here a is a very good one (heat dissipation)
Flirc for rpi4

I just ordered one. But when when you order one it automatically adds their IR receiver into the cart. You have yo go in and delete it. I find that a little under handed of them.

John S.

Just tried to load up serial json for PI4. everything worked until I came to this command: pi@raspberrypi:~ $ cd serial-port-json-server-1.96_linux_arm
pi@raspberrypi:~/serial-port-json-server-1.96_linux_arm $ chmod 777 serial-port-json-server-1.96_linux_arm
chmod: cannot access ‘serial-port-json-server-1.96_linux_arm’: No such file or directory
Getting closer tried to resolve this error. I did not have any success. Thanks in advance for your help, Allen

Just skip that step. It makes the binary executable, but it likely already shows as executable.

This is my results w/ next command: pi@raspberrypi:~ $ cd serial-port-json-server-1.96_linux_arm
pi@raspberrypi:~/serial-port-json-server-1.96_linux_arm $ sudo ./serial-port-json-server
sudo: ./serial-port-json-server: command not found
pi@raspberrypi:~/serial-port-json-server-1.96_linux_arm $ sudo ./serial-port-json-server -createstartupscript
sudo: ./serial-port-json-server: command not found
Allen

Do an “ls” in that directory and what does it output for you?

pi@raspberrypi:~/serial-port-json-server-1.96_linux_arm $ ls
arduino README.md sample-cert.pem sample-key.pem serial-port-json-server

Ahh, I think I know. Do chmod 777 serial-port-json-server instead of chmod 777 serial-port-json-server-1.96_linux_arm and then you’ll get that binary executable and that solves the next error you’re seeing.

John that seams to allow the rest of the commands to operate. Checking to see if it will find the port in CP, Thanks, I’m new to pi and linux; Allen