50W Power Supply issues, Laser will not fire, everything else seems to be working

I just purchased a 50W laser on Ebay and I am having troubles getting the laser to fire. I think I received a 220v unit, as it states it on the label and there is no switch on the power supply, just a hole where the switch would go. The air & water pump were both 220v as well, when I contacted the seller he stated :

There’s a built in transformer, either 110V and 220V will work, please don’t worry. As long as the power supply shares similiar parameters as the one we install, either 110V and 220V will work.

Is that true, why do most come with a switch to select input voltage?

The power supply does light the led’s, move the gantry and power the bed, nothing seems sluggish, but I don’t know how fast it should move.

The laser fired a few times, but was very weak, now it doesn’t fire at all, but everything else works.

The tube looks very good there are no visible cracks that I can see, and water flows though it with no problems.

*Edit - I also purchased a CloudRay 50W power supply and tried to see if I could get the laser to fire with the test button on the LPSU, it powered up then stopped, turned out to be a blown fuse which has the markings F5AL 250V.

I did remove the ground lug, removed the paint around the hole so there is a good connection for the grounding wire.

No. A transformer is designed to work at a specific voltage. You have to supply it with the voltage it is rated for.

The power supplies are a different story. Many of them will either be universal (ie. they work with a wide range of input voltages) or they will have a selector switch as you noted. Some do use fixed input voltages though; usually the cheaper supplies are of this type.

Is there any way to tell if this power supply can work off of 110v or 220v, other than the label only stating 220V? Otherwise, I guess it must be the tube, I don’t see any sensors attached.

Chances are pretty good it’s just lost in translation. I’ve often seen switching power supplies listed as “transformers” and I think it’s due to translation, it’s not intended to be English engineering terminology.

1 Like

Unless this supply is different than I have worked on [can be verified by seeing the inside], it need the 120/230 selection switch.
Perhaps they have strapped the supply internally to 115V even though it says 220. They could do that simply by adding a jumper where the switch normally goes.

These assertions are based on my knowledge of the typical LPS shipped with these machines. If this is a different supply these may not apply.

  • They are not off-line switchers (universal) like most modern supplies…
  • Transformer supplies usually have taps for different voltage and the switch selects the associated tap. This supply’s power selection switch does not work that way.

The input circuit looks like this:

And it works like this:

Is that big wire wound thing (img _1074.jpg) connected to the LPS?

Did you ever get the CloudRay supply to work? If you can get it working with the CloudRay that eliminates the new supply.

I would test the other elements of the LPS using my troubleshooting guide to see if the problem is elsewhere. This will also verify that the DC voltages are correct.

If the supply should be strapped to 115 and it’s not then the HV drivers will be running at 1/2 their expected voltage. I would guess the HVT would put out maybe <10,000v instead of 20,000v. Don’t know if this would fire the laser or not. This lower voltage may be enough to allow the low voltage supply to work or work marginally.

I may be able to tell if the supply is strapped to 115v if I can see pictures of the connectors and the LPS PCB with the cover off.

No, when the fuse blew I disconnected the Cloudray supply, plus the original supply had a 20v output that I didn’t see on the Cloudray lpsu, which I am assuming it is for the DC motor to raise/lower the bed.

I haven’t been able to find any documentation for this LPSU in 50W.

The seller is sending me a new supply, if that works I’ll ship this one out to you @donkjr so you can fiddle with it, might be one you haven’t seen yet.

in the mean time can you send me pictures :)!

That supply is slightly different.
That “AC110V” jumper is not on any of my supplies.
Is that jumper shorted? That may be how they are selecting the power range …
I think I see a wire but no solder?

Short out the 115 jumper pads and give it a try.

Possibly, but there is a toroid transformer in one of the pictures.

Also, you don’t need to correct me every time I post.

Seller shipped new power supply, installed it and now everything is working.

Thank you everyone for the help.

1 Like

Does the new one have a voltage selection switch?

No. looks the same.