3018 500w spindle speed control with Annoy Tools Board

I just upgraded my 3018 to the latest Annoy Tools controller (transparent blue case) with 48v DC direct drive brushless spindle control on-board. Motion control works in all ways but no gcode sender sees the spindle as available. I’ve tried four different sender packages and the spindle is either grayed-out or not visible on the any app’s main screen. I’ve even tried a second controller… No love.

$32 is set to “0” and the offline controller works perfectly allowing spindle start/stop and speed control so I know that much of the board is functioning but there doesn’t seem to be programmed control function. This has driven me to avoid rooms with sharp objects in them. :scream:

Ideas? Anyone?

At least for their new 32-bit units, they advertise wide sender compatibility, and install GPL firmware on their device and then try to keep you from upgrading it, I see. :cry:

Can you post the entire $$ output?

Tnx for responding!

$0 = 10    (Step pulse time, microseconds)
$1 = 25    (Step idle delay, milliseconds)
$2 = 0    (Step pulse invert, mask)
$3 = 6    (Step direction invert, mask)
$4 = 0    (Invert step enable pin, boolean)
$5 = 0    (Invert limit pins, boolean)
$6 = 0    (Invert probe pin, boolean)
$10 = 1    (Status report options, mask)
$11 = 0.010    (Junction deviation, millimeters)
$12 = 0.002    (Arc tolerance, millimeters)
$13 = 0    (Report in inches, boolean)
$20 = 0    (Soft limits enable, boolean)
$21 = 1    (Hard limits enable, boolean)
$22 = 1    (Homing cycle enable, boolean)
$23 = 0    (Homing direction invert, mask)
$24 = 800.000    (Homing locate feed rate, mm/min)
$25 = 3000.000    (Homing search seek rate, mm/min)
$26 = 250    (Homing switch debounce delay, milliseconds)
$27 = 25.000    (Homing switch pull-off distance, millimeters)
$30 = 1000    (Maximum spindle speed, RPM)
$31 = 50    (Minimum spindle speed, RPM)
$32 = 0    (Laser-mode enable, boolean)
$38 = 10   
$39 = 7   
$100 = 160.000    (X-axis travel resolution, step/mm)
$101 = 160.000    (Y-axis travel resolution, step/mm)
$102 = 160.000    (Z-axis travel resolution, step/mm)
$110 = 8000.000    (X-axis maximum rate, mm/min)
$111 = 8000.000    (Y-axis maximum rate, mm/min)
$112 = 100.000    (Z-axis maximum rate, mm/min)
$120 = 500.000    (X-axis acceleration, mm/sec^2)
$121 = 500.000    (Y-axis acceleration, mm/sec^2)
$122 = 20.000    (Z-axis acceleration, mm/sec^2)
$130 = 300.000    (X-axis maximum travel, millimeters)
$131 = 180.000    (Y-axis maximum travel, millimeters)
$132 = 60.000    (Z-axis maximum travel, millimeters)

“… and then try to keep you from upgrading it, I see. :cry:

Sleazy, huh? :face_with_raised_eyebrow:

Michael?.. Hello?

I have been insanely busy. Also I haven’t set up my own CNC with spindle control. I figured the $$ output would help others who have done this help out as a first step. And you have 30, 31, and 32 set.

It’s possible that the grbl version it is running (unspecified) sends a status response (not shown) that the senders don’t recognize.

The fact that it works at all means that the init/hello message must be recognized. This makes me think that the status message might not be fully recognized. But you haven’t shared any information about what senders you have used, or any of the normal output from the board. I’m not personally an expert in what the different senders expect in the init and status messages, but others might know if you share what senders you have tried and what status messages the board is sending. Or they might not. But it’s hard for anyone to guess without seeing examples.

Not having the board to see the init, I’m just guessing that it being newer it might be running grblHAL. Here’s their documentation on the status messages:

That includes spindle information.