Trouble connection to Smoothieboard

After switching to a new PC (Windows 8.1 Pro x64), I have trouble to connect to the SmoothieBoard via Pronterface/Repetier Host.
When I plugged in the Smoothieboard for the first time it automatically installed the sd-card drivers and I have no problem accessing it, also when installing the SmoothieBoard drivers itself there was no problem.
Then I opened up Repetier Host and connected to the printer, but it keeps saying “# Command Waiting” and that number adds up when I send a command. With PronterFace I get the following error: “[Error 31] A device attached to the system is not functioning”.

I already removed (reboot PC) and reinstalled the drivers (first 1.0 and second 1.1), but at most I can send 1 command (like HOME) and then it stops responding. Also updated the firmware on the board itself, but no improvements.
Tried 3 differend USB cables & other USB ports.
I also have tried it on 2 other pc’s (also with Windows 8.1 Pro x64) and with those pc’s it works flawlessly.

Imported from wikidot

Hi Speedtoucher

i had the same troubles wih my laptop win 8.1. to solve it, I disabled the SD drive in the periphical system management ( MBED USB DISK USB Device) .
I can print now :slight_smile:



You can also try this :


I may run into the same problem after upgrading the firmware (my last update was ~dec 2018)

After updating I cannot connect to the board via the COM-port. When I do a rollback everything is fine.

  • Did a file compare on the config files (my current and the one currently on GitHub,) but apart from some commented lines did not see anything new.
  • Also tried to disable the MSD by installing the supplied FW and setting the msd_disable setting to true

Only thing I did not swap out was the SD card, but since it’s reading the FW updates quite fine I recon that that couldn’t be the problem.

Does anybody have an idea how I approach this?

Running Windows10,
Config file >

Can you try disabling network and panel and see if you see an improvement ? If so you might be running out of RAM.

Hey Arthur, Thanks for the fast reply,

I don’t have Ethernet capabilities on my board, nor is there a panel attached. Both are disabled in the config file.

Try disabling other things to see if it changes, like switches, temperaturecontrol, whatever else

ok!, will do!