Too much chatter for me to mill my PCB.

Too much chatter for me to mill my PCB. I have an OX CNC and I guess I’ve never milled anything this small to notice. What do you think is going on?

What controler are you using? If you are starving it due to lots of small moves it can’t do the motion planning properly.

Maybe you can increase your micro stepping resolution.

I saw your video after my last post. I definitely think you should look at maximizing your microstep resolution. That should give you very smooth motion. Also, you may need to adjust your steeper current some, but definitely look into micro stepping settings first.

26.67steps per mm??? Seems low. What is the microstep setting on your stepper driver?

Is the current set right on your motor drives? The way it is running it looks like the current is too high. I made the G Code a really weird way when I isolation routed a PCB. But I did that because I had to cheat with the board size I needed on my free copy of Eagle I used. That was due to some heat sink clearance I needed on a part. So I had to stretch things out a bit. I ended up exporting the board art as an image, editing the image in an image manipulation program, then importing it into a vector graphics program to make it into a DXF, then I processed that into G Code.

It made a really nice G Code file that my machine ran good though. I could really tweak the shapes of everything doing that too.

I used Eagle for the board art and exported a PNG > into GIMP to stretch it out > imported that into InkScape to make the DXF (hand traced - InkScape’s automatic tracer is sucky - it makes too many nodes, is brain dead) > dfx2gcode to generate the G Code

What cnc controller are you using on you ox?

I think your steeper current settings may be a bit too high also. You should monitor your steppers for over heating to confirm this.

fwiw my dedicated pcb mill runs the spindle at about 15,000 rpm. When I’ve tried doing stuff on my cnc mill, even with the spindle going as fast as it can and the mill just creeping along I still get ragged edges.

You should look at this referrence for setting your micro step configuration. In here they suggest using 40.2 steps/mm x and y using gt2 belt.

Both of these should give you smoother motion.

I agree… sounds like microstepping isn’t set correctly

I run quarter step

I’d set it to 16x microstepping and I would check again to see if most of that is gone.

@Paul_Frederick ​ Why don’t you use chilipeppr, it has an Eagle board import widget that can do all the work for you, and if you find any feature that is missing or found any bug you can post that on github project page and we can take it in consideration with future updates.
If your CNC controller is not supported by Chilipeppr you can still import your boards, generate the gcode then copy to anywhere you like.

because I use LinuxCNC. I cannot import a board Eagle is not going to let me make either, now can I?

Try 1/16 stepping, then change/check step/mm

Also, make sure your belts aren’t too tight, and also that wheels aren’t too tight. There is a “happy medium” it takes awhile to find @Rob_Mitchell1

I use the Spark Concepts CNC XPRO v2 controller. I have 1/8 micro step.

Here is the link to the controller.


I haven’t used that controller myself, but it says it’s able to do down to 1/32 micro stepping. I would try 1/16 since your at 1/8. Let me know if it works. Are you familiar with adjusting firmware?

@Mark_Leino ​ the board has jumpers to adjust micro steps. I’ll give that a shot and cross my fingers.