Today, I installed a z probe in my xcarve because I want to use

gplus
(Greg King) #1

Today, I installed a z probe in my xcarve because I want to use the auto-level function in Chilipeppr. I have the xyzcarve from Ben Harper - using the GRBLAIO board.

Anyway, in Chilipeppr i setup and run the autolevel - it proceeds to touch first point at 0,0 then stops. More troubleshooting when I get some free time, however the Z probe has been tested successfully with Easel to find the work surface.

I noted some comments from 2016 suggesting a bug was introduced and fixed in TinyG but not GRBL - hoping it is.

Also, I am using straight untwisted wiring for the probe - i did read some comments on interference - unsure if that is contributing

I want to get the levelling function working to cut some sweet etchings :slight_smile:

Thanks!

(JOHN LAUER) #2

If you manually run the Z probe in ChiliPeppr, does it work then? Does it just fail on the full auto-level?

(Justin Adie) #3

There was a bug in grbl relating to layers. Fixed in the jpadie workspace (which also works for grbl 0.9x providing you are in metric).

(Greg King) #4

I may have been using the grbl workspace as I was switching between the two :stuck_out_tongue:

Good news is I have it working - once I got reasonable settings for the auto level process.

I also got confused with the auto level test probe - I was expecting it to backoff 2mm after contact but it doesn’t

Thanks every, this is an awesome resource !

(Greg King) #5

Next question, is probe offset supported ? I’m using a touch plate for now, but will replace with a pointy switch.
For the touch plate, I can run an auto level, then return to 0,0,0 then drop Z down by the touch plate thickness, re-zero , then run the cut