SOLVED Hi all! I have a little problem with Laserweb 4.

Hi all!
I have a little problem with Laserweb 4.
In the control page I cannot move the pointer with the arrows and the position display doesn’t changes (but in the bottom-right command window I can see the jog commands). Even the “run” command doesn’t send any command to GRBL and no commands in the window.
I checked all setups and obviously I connected a GRBL 1.1 board.

I tried to load other versions of Laserweb, back to 4.0.728, and all versions have the same behaviour.

So, I suspect that here is some setting file that is corrupted or incompatible (in the past I tested older versions), but I cant find such files.


Thanks in advance.

(OSX 10.12.5)

UPDATE: in the library>application support I found a folder called lw.comm-server and I removed it. I loose all setups, but the problem still occours.

Any ideas?

What does grbl $10=?

@Ariel_Yahni_UniKpty $10=?<Idle|MPos:0.000,0.000,0.000|FS:0,0|Ov:100,100,100>

You need to type $10

It should be 0

UPDATE: after cleaning files and reinstalling, now Laserweb sends correctly g-code to GRBL.
Anyway, preview windows and DROs still are frozen at 0-0-0

@Ariel_Yahni_UniKpty GREAT!
I Finally understand tha LaserWeb gets the position from GRBL, so if the parameter $10 is not correctly configured, no or wrong position feedback come bact to LaserWeb.