So I wanted to share my recent experience with my OX.

(Matt Herrera) #1

So I wanted to share my recent experience with my OX. I’ve cut plenty of wood and usually with no issues. However occasionally my OX would loose position and ruin a cut. I thought it was bad G-code or glitchy software and didn’t give it much thought it really only happen maybe 2-3 times before. Than recently I was working with some very hard rose wood and my Ox would not make a straight cut until I slowed my feed rate way down 20ipm and changed my cut per pass to 0.020". This caused even minor work to take forever.
I was holding the X axis during a cut to see if I felt vibration or something before it went astray and I noticed my X axis moved by the touch of my hand? Ok I knew that shouldn’t happen and then it dawned on me. I had my motors set to power on when moving (Mode 3) this was recommended by someone when I was searching how to configure my TinyG. The problem here is if my Y axis is moving my X axis is just a sitting duck with no power no torque to hold it in place. Working with this hard wood caused the X axis to move all over the place. I went back into TinyG with coolterm and changed the settings on all my axis to (mode2) “power on when in cycle”. This causes all stepper motors to have power and torque any time any movement or any stepper motor is moving or “in cycle”. Once I made that change my problem was solved. I thought I would just share this with the group for any other newb who is experiencing a similar issue.
One other sign I should have caught onto much sooner was that my machine would not always go back to my zero position when I would command it to. Sometimes it would be just slightly off, again I chalked it up to an imperfect hobby grade machine but I now believe it was my axis wondering slightly due to the setting it was on. I hope this helps someone.

(Matt Herrera) #2

Forgot to mention the setting is under PM (power management). For example motor 1, $1pm=2 I had mine originally set on 3.

(Milos Vajdic) #3

And i was just about to use a hammer on my Ox. Fixed the issue for me as well :smile: thank you

(Matt Herrera) #4

Nice glad it helped and saved an OX from the grave! :+1:t4:

(Michel Pollet) #5

grbl also has a mode that power off the motors when not in use. Sure it reduces heat, but you lose position; kinda silly. On grbl the setting is $1=255 (to disable power off)

(Brandon Satterfield) #6

Solid advice @Matt_Herrera ! Great post, thank you for sharing.

(Brandon Satterfield) #7

Solid advice @Matt_Herrera ! Great post, thank you for sharing.

(Mark Green) #8

Thanks. I’m just starting to wire my OX and it’s good to know I’ll have it configured correct from the start.

(Dennis Espinosa) #9

thanks for the tip! :slight_smile:

(Matt Herrera) #10

I’m glad this is helpful! And yes @Michel_Pollet my thoughts exactly, I can replace a $30 stepper motor occasionally if needed but I don’t like to have hours of work ruined by one mistake or to have expensive exotic woods destroyed. I’ve noticed my motors don’t run very hot anyways. There is a voltage adjustment on the TinyG for the motors and I left my as they came stock but I suppose if someone adjusted the voltage the heating issue could be a larger problem.

(Jérémie Tarot) #11

Kind of priceless tip for brand n00b like me
Thanks a lot :+1:

(Michel Pollet) #12

+Matt Herrera If they run very hot perhaps you drive them with too much current? Are they making a ‘happy’ noise when moving? Setting the ‘right’ current takes a bit of time; too little and you’ll miss steps, too much and you’ll overheat…

(Matt Herrera) #13

Mike sorry if I wasn’t clear in my post. My motors don’t run hot. I was saying a stepper could run hotter in mode 2 if the current on the pot Was set too high.
My pots are set as they came from the manufacturer and my motors run cool, although I have considered tinkering with the pots to see if I get any better performance.