So GWizard can't simulate 4 axis (for another few month at least).

So GWizard can’t simulate 4 axis (for another few month at least).
NCPlot is extreeeeeemely slow to the point of being unusable and not reacting to Windows messages and being force-closed.

What other options to simulate 4 axis g-code exist?
I’m not comfortable to debug my in-development CAM software on my physical machine.

You can do simulations in LinuxCNC. Is that not an option?

No Linux at the moment and no space nor time to install it on my tiny MacBook just to try one app.

Found a 15 day trial of a Windows program that simulates 4 axis.
Debugged my algorithms with it today.
Real 4 axis g-code generation works now.

I have LinuxCNC 2.5.1(sim) installed in LinuxMint9 and your jar file running also. Do you have any stl files that you know work? I tried this owl:


But I think it’s to big - are there any stl file size limits?

I tried with fairly large models.
Takes ages but works.
Don’t be confused about the g-code panel now showing any code after a few seonds.
I’m running into an arra limitation there but the save -button still works (and all g-code is written to a temporary file right away anyway)

I put all the known issues into the issue-tracker on Google Code.