Smoothieboard freezes after 1 hour of printing

Hey guys, I too am having a problem with my smoothieboard and it having random “freezes while printing” but it is not quite a freeze and not quite random. I’m going to breakdown what I see and hear and the solutions I have tried so far.

Smoothieboard X4c order spring 2015.
Kossel Mini Delta Printer

Printing via octoprint
Simplify3D and Cura as slicers

Note: I have been using the same gcode file for the entire process

Printer was running fine until a month ago, when the thermistor broke during removing ABS that had stuck to the hotend. I turned off the system and it has been sitting off for a couple of weeks now. Finally got around to replacing the thermistor, and turned the printer back on to calibrate, etc. Updated the smoothieware to the most recent version. (Edge branch on 4/24/2016). It worked fine. It even prints fine if the print is under 1 hour in duration. (I have not tried consecutive one hour prints yet, I.E. print one thing, take if off the bed, then immediately print another thing). However after approximate 1 hour of printing, the 3D printer stops all x,y,z,e actions, and produces a high pitch whine from the stepper motors, with the loudest hum coming from the extruder’s stepper motor. The heated bed and hot block do maintain temperature control, (I have a current meter set up to monitor how much power is drawn from the power supply, and it is fluctuating in time to the LEDs by the power mosfets running the hotend and heated bed). All the LEDs are solid except for LED3, which is blinking.

Attempted Solutions:

  1. Rolled back smoothie. I have run the printer on the version I had running before and the current master branch. It still experiences the “freeze” after one hour of printing
  2. Adjusted motor’s currents, tried reducing it to .75A then increasing it to 1.5A, did not seem to have an effect.
    3)Printed from SD card instead of octoprint, still “froze” after ~1 hour.
    3)Disconnected extruder’s stepper motor from smoothieboard. Still “froze” after approximately an hour of printing, but the loudest high pitch wine did go away.
    4)Actively cooled smoothieboard, I placed a desktop fan blowing directly on the smoothieboard to try keep it cool, in-case the shutdown was caused by a thermal overload on some of the ICs, The print still froze (and while I did not write down the exact start and stop time, it was still within that approximately 1 hour window).
    5)Checked gcode file for F0 or other funky movement commands, I did not see any.

Next attempt at solution:

  1. Print something else already on the octoprint server that printed successfully before
    2)Disconnect all stepper motors and see if it still freezes

Anyone have any ideas or some solution I skipped? I’m starting to pull my hair out here.


William Gerhard

Imported from wikidot

I haven’t solved my freezing issue yet but my next theory of why Smoothieboard is freezing could be due to the SD Card failing to keep up with read speeds. I just purchased a new SD ( I believe class 6 ) card and will try that instead of my old SD ( class 4 ) card

But I’ve tried printing over USB and SD card, and in using this board for over a year now, I’ve never had it have a problem with printing over USB.


Just ran the printer will all the stepper motors disconnected from the smoothie board. After an hour once again the system froze. The serial terminal on octoprint says “Communication timeout during print”.

Any ideas of a solution other than buy a new smoothieboard?

Can you try using this file on your gcode file : and tell us if it still crashes.
Don’t waste plastic, do this without the motors as you just tried.


That fixed it! First time I have ever had an issue with Simply3D and Smoothie.

Thanks Arthur!

Hi Guys,

just want to share my experience.
I had the same issue and investigated the gCode and so on. But there was no problem at all.
My smoothieboard freezed after 57-68min. LED 1 and 3 where off, LED 2 and 4 on.

After shortening the ribbon cables to the GLCD display to 15cm, the problem was gone!
Print was from internal SD.

This is the second negative point I found beside that the external SD is not working at all.
(It is configured properly, but on access, smoothie board freezes, too)

Now I have to find a place for the display in 15cm vicinity on a prusa i3… :frowning: