Simple jobs do not complete

LaserWeb information

On the About page, I see that I have:

  • Frontend version: 4.0.996_________
  • Backend version: 4.0.136_________

My settings are:

  "settings": {
    "__version": "4.0.996",
    "__selectedProfile": "*gen_grbl",
    "__latestRelease": "2019-11-26T10:42:57Z",
    "showMachine": false,
    "machineWidth": 300,
    "machineHeight": 200,
    "machineBeamDiameter": 0.2,
    "machineBottomLeftX": 0,
    "machineBottomLeftY": 0,
    "machineFeedRange": {
      "XY": {"min": 1, "max": 50000},
      "Z": {"min": 1, "max": 50000},
      "A": {"min": 1, "max": 50000},
      "S": {"min": 0, "max": 30000}
    },
    "machineXYProbeOffset": 0,
    "machineZEnabled": false,
    "machineZMatThickness": 0,
    "machineZToolOffset": 0,
    "machineZStartHeight": "",
    "machineZProbeOffset": 0,
    "machineAEnabled": false,
    "machineBlowerEnabled": false,
    "machineBlowerGcodeOn": "",
    "machineBlowerGcodeOff": "",
    "pxPerInch": 96,
    "forcePxPerInch": false,
    "dpiBitmap": 300,
    "toolGridWidth": 400,
    "toolGridHeight": 300,
    "toolGridMinorSpacing": 10,
    "toolGridMajorSpacing": 50,
    "toolSafetyLockDisabled": false,
    "toolCncMode": false,
    "toolImagePosition": "BL",
    "toolUseNumpad": false,
    "toolDisplayCache": false,
    "toolUseGamepad": false,
    "toolCreateEmptyOps": false,
    "toolVideoDevice": null,
    "toolVideoPerspective": {"enabled": false},
    "toolVideoLens": {"a": 1, "b": 1, "F": 1, "scale": 1},
    "toolVideoFov": {"x": 1, "y": 1},
    "toolVideoResolution": "720p(HD)",
    "toolVideoOMR": false,
    "toolVideoOMROffsetX": 0,
    "toolVideoOMROffsetY": 0,
    "toolVideoOMRMarkerSize": 20,
    "toolWebcamUrl": "",
    "toolFeedUnits": "mm/min",
    "toolTestSValue": 1,
    "toolTestDuration": 0,
    "gcodeStart": "G21         ; Set units to mm\r\nG90         ; Absolute positioning\r\nM4 S0       ; Enable Laser/Spindle (0 power)\r\n",
    "gcodeEnd": "M5          ; Disable Laser/Spindle\r\n",
    "gcodeHoming": "$H",
    "gcodeGenerator": "default",
    "gcodeToolOn": "",
    "gcodeToolOff": "",
    "gcodeLaserIntensity": "S",
    "gcodeLaserIntensitySeparateLine": false,
    "gcodeSMinValue": 0,
    "gcodeSMaxValue": 1000,
    "gcodeCheckSizePower": 0,
    "gcodeToolTestPower": 75,
    "gcodeToolTestDuration": 300,
    "gcodeConcurrency": 5,
    "gcodeCurvePrecision": 1,
    "comServerVersion": "4.0.136",
    "comServerIP": "192.168.86.31:8000",
    "comServerConnect": false,
    "comInterfaces": ["USB", "ESP8266", "Telnet"],
    "comPorts": [
      {
        "manufacturer": "FTDI",
        "serialNumber": "D306OF5U",
        "pnpId": "usb-FTDI_FT230X_Basic_UART_D306OF5U-if00-port0",
        "vendorId": "0403",
        "productId": "6015",
        "comName": "/dev/ttyUSB0"
      },
      {"comName": "/dev/ttyAMA0"}
    ],
    "comAccumulatedJobTime": 1485,
    "connectVia": "USB",
    "connectPort": "/dev/ttyUSB0",
    "connectBaud": "115200",
    "connectIP": "192.168.86.31",
    "jogStepsize": 10,
    "jogFeedXY": 800,
    "jogFeedZ": 300,
    "macros": {
      "*GotoXY0": {
        "label": "Goto XY zero",
        "gcode": "G0 X0Y0",
        "keybinding": "ctrl+f1",
        "_locked": false
      },
      "*LaserOff": {
        "label": "LASER OFF",
        "gcode": "M5",
        "keybinding": "ctrl+f2",
        "_locked": false
      }
    },
    "uiFcDrag": null
  }
}
<go to Settings / Tools and save your LaserWeb Settings to a json file, 
then open that file with a text editor and copy/paste the content here>

Problem description

When I run a job, even a simple ellipse___, I expect it to complete_, but instead moves to the location, gets about halfway through an object and then it stops. The laser stays on until I abort and turn off laser. It will re-start another job without any problems but never finishes_ happens.

This problem is | has always happened.


## System description

* My machine is a | diode laser | 

* I have a tinyg

* It has NAME_OF_FIRMWARE version VERSION_OF_FIRMWARE installed

* I connect via USB to rPi running server and through websocket to MacOS running frontend

* My computer(s) on which I run LaserWeb run(s) <!-- choose all that apply -->  Mac version catalina

Here is my configuration:

<paste the contents of your machine configuration file or $$ output here>


<!-- Please insert a relevant picture or screenshot to help describe your problem by dragging and dropping the picture into the text edit box with your cursor below, or by choosing the upload icon in the toolbar above (with the upward-pointing arrow) and choosing the image to upload. -->