Ruida controller not accepting values

Very new to all this, any advice appreciated.
I have a RDD6584G connected to a fabric cutting bed. Although during setup we managed to get some successful cuts, things have only deteriorated.
The vibrating knife used ‘D’ axis for blade depth, this can be manually adjusted to the correct depth, but the control box does not save the values.
i.e. ‘Up coor’ and ‘Down coor’ remain at zero.
Consequently all cuts are performed with the cutting head located at zero, in this case is approx 80mm above the table.
I am willing to try anything at this stage as nothing seems to work.

1 Like

Hello… Welcome aboard… :grin:

I know very little about these controllers and will have a look at yours. I run a Ruida on my co2 laser, so I have some familuraity with these.

Others attempting to help or curious, here is the site link and a pdf of the controller manual.

RDD6584G-Control-System-V1.3-Manual.pdf (4.2 MB)

If I run across anything I think might help, I’ll post it…

Good luck