Recently got my printer back up and running,

gcodeprintr-problems
gplus
(Carlos Cervantes) #1

Recently got my printer back up and running, noticed that there was an update to v3.03.

Updated and i love the new features! However, i am having 2 peculiar issues;

  1. Prints often show the percentage as a negative, when this happens and the print completes, it shows 0%. This causes my printer to attempt printing in the home position.
  2. I get random layer shifts; small and big, for no reason during prints - sometimes, not at all.

Using Prusa Slic3r and octoprint port for printing.

0 Likes

(Carlos Cervantes) #2

found out that; if send a gcode to the UI (no matter which way) then print, stop, then print the same gcode again, it’ll correct the percentage.

0 Likes

(Mathias Dietz) #3

@Carlos_Cervantes , thanks for the feedback. I’m aware of the problem with the wrong percentage , it happens to me from time to time as well, however this is just a reporting issue and should not impact the print itself.
Regarding the layer shifts, this is unlikely to be caused by the App. Layer shifts usually happen if your stepper motors loose steps or if your belts are slipping.

0 Likes

(Mathias Dietz) #4

@Carlos_Cervantes you use slic3r to upload the gcode to the App through the web interface (octoprint upload) , right ? Could you please try if loading the file through the app is any better ?

0 Likes

(Carlos Cervantes) #5

@Mathias_Dietz
I’ve recently figured out my layer shifting problem; a combination of firmware, gcode, and calibrations (pulls, belts, etc)

As for the time percentage, i’ve tried multiple different ways - same results.
-Octoprint upload (main method)
-Dropbox
-through the web interface

Only method i haven’t tried yet is using the java applet to send the gcode to the printer, mostly because i can’t find that applet anymore.

0 Likes