Pulling my hair out with my k40

(Donald Bardinelli) #1

My K40 died last October, I thought it was the power supply but replacing it didn’t seem to do the trick. I then purchased a new tube from LO, installed it but now get no power (no green led).

I thought it might be the safety switches, but I am getting 120v across the leads on the power supply so they are making contact.

I tried the original power supply with the same results, there doesn’t seem to be any sensors on my machine. I tried unplugging the two connectors leaving only the power and that didn’t do anything. I guess it could be possible that both LPSU are bad, but I used to get the green light even when it failed.

I’m wondering if the digital board died, but wouldn’t the LPSU at least power on?

It happened my k40 died after a year and 3 months
(Don Kleinschnitz Jr.) #2

There is a fuse on the inside of those supplies.
Unplug the supply, remove the cover and test the fuse.

1 Like
(Donald Bardinelli) #3

The fuse seems good the 0.0L changes value, and I get a tone for continuity.

(Don Kleinschnitz Jr.) #4

So to summarize:
Your LPS led (green) is not on when there is power to the supply [as tested at the connector] and this is brand new supply?

(Donald Bardinelli) #5

Yes, and I just tried the new supply I got today and still no luck?? The fuse in the IEC plus is good, the fuse in the supply is good, I rechecked ground. The only thing I question is if I wired the new e-stop switch correctly. But I figured I did, if I am getting 120V at the supply.

(Donald Bardinelli) #6

This is with the e-stop button pushed in.

(Donald Bardinelli) #7

Here is with the e-stop button out (run Mode)

(Don Kleinschnitz Jr.) #8

Is the voltage switch on the side of the LPS in the correct position.
It can be set for 220 and 120.

Your measurements are measured from either side of the line to FG???
Are you running on 220v?
What does it read across AC to AC on the connector?

I am focusing on why the supply does not turn on with proper voltage to it BUT…

  • I am wondering why there is a difference in voltage from FG to either side of the line of 2.5v?
  • Was this working after you replaced the Estop

It would be helpful to recite the sequence of everything that has been replaced and in what order with what symptoms before and after.
Sorry but I have lost track …

(Donald Bardinelli) #9

I’m an idiot, not all e-stop buttons are the same! The original is NC, the one I bought is NO. Swapped out the original switch base and she powered up. Sorry for wasting your time on this Don, but thank you for the help anyway. Also, it seems that the original LPSU might still be good (no squealing) , so it was the tube that went bad.

3 Likes
(Don Kleinschnitz Jr.) #10

It happens but I am still puzzled why the LPS would not power up with voltage on it. Were the readings wrong?

1 Like
(Donald Bardinelli) #11

So I took readings with the correct switch (NC) in place, not really understanding what I am seeing, but it works.

Switch disabled (power on)


Switch enabled (power cut)


This shows the switch in action.

(Don Kleinschnitz Jr.) #12

Is this running 120V service?

At least now it looks logical:
When the switch is on

  • Left AC pin to FG is 120V = Correct and this is the HOT side
  • Right AC pin to FG is close to 0 ACV = Correct, this is Neutral side
  • I would assume that measuring from the left AC pin to right AC pin would = 120V?

I assume the switches outputs are connected to the right and left AC pins on LPS right?

(Akai Coit) #13

Thanks for directing me to this thread, but just to clarify, this fix initially started because the power output of your machine would drop sharply during use, correct? That’s what’s happening for me and I wanna make sure I’m following the right path. Will bow out and avoid hijacking this thread if my issue is different.

(Donald Bardinelli) #14

Yes it is 120v, I didn’t want to unravel the wrapping, but the wires come out of the bottom of the switch and go into the AC left and right pins judging by the color of the wires.

(Donald Bardinelli) #15

I replaced the LPS first, but that did not fix the issue, so I replaced the tube, and that got me back up and running.

(Akai Coit) #16

Going to start looking up replacement tubes this weekend. Suggestions?

(Donald Bardinelli) #17

I purchased a LO 40w, I think it was $145 plus shipping. The quality seems so much better than the stock tube that came with mine. I took Don’s advice and purchased a HV connector.

1 Like
(Donald Bardinelli) #18

Here is a link to the connectors.

https://www.amazon.com/gp/product/B01N2XOOYN/ref=ppx_yo_dt_b_asin_title_o09_s00?ie=UTF8&psc=1

(Don Kleinschnitz Jr.) #19

Now you need interlocks and a ma meter on that machine :wink:

Those tube mounts look nice, where did you get them?

(Don Kleinschnitz Jr.) #20

@PrintinAddiction what plans do you have for you dead tube?
I have been looking for one to do some HV testing.