Problems running laserweb on lubuntu: OpenGL won't start


I had been using jscut to generate gcode for my CNC router and recently decided to try lasercut. Unfortunately I am unable to run it on my linux machine for some reason. Can someone help me?

I am running this appImage:


And after it runs a bit it then puts up a white page with the following error:

OpenGL won’t start. This app can’t run without it.

My openGL info is:
glxinfo |grep OpenGL |grep version
OpenGL core profile version string: 4.5 (Core Profile) Mesa 23.0.4-0ubuntu1~22.04.1
OpenGL core profile shading language version string: 4.50
OpenGL version string: 4.5 (Compatibility Profile) Mesa 23.0.4-0ubuntu1~22.04.1
OpenGL shading language version string: 4.50
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 23.0.4-0ubuntu1~22.04.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

Any help is greatly appreciated.

Thank you for your time!

So you need to run laserweb-builder in order to run lasercut? That sounds sus.
Besides, laserweb is a Windows-only app IIFC
Correction: LaserWeb is a JavaScript front end(browser)and backend(web server). The nodeJS can run the backend while a modern browser runs the client side so platform neutral.

Looks like LaserCut is a Java based application so it runs on anything which has a Java runtime with GUI support. No idea why you’d try to run LaserCut by running a laserweb build image.

Hi @azox , welcome!

As @dougl says LaserCut and LaserWeb are two different things. I’m assuming you mean LaserWeb here :wink:

The Appimages online are generally rather old; I would expect problems running them on newer distro versions.

Can you please point me at the source for your Appimage? (where you got it from)? since I’d like to try this myself on my home system.

That said; I think there are better ways to run LW on linux; running lw.comm.server directly as a service. How competent are you on the commandline?

Actually, Laserweb is a Javascript application and runs in your web browser. It’s /really/ cross platform (*)

It has been packaged several ways; into a Electron Image for use on windows, as an appimage for linux, as a NPM package and as Docker images.

All the above are now elderly and starting to break. I dont have the skillz, time or mental space to fix this.

Currently I run Laserweb by running lw.comm.server (cloned from git) in NPM, then browsing to localhost:8000 in my browser. I’m on Fedora 40 and WebGL ‘just works’.

I run this on a PI attached to the machine via USB serial; and this gives me ‘OctoPrint for my CNC’,

(*) So long as your browser handles WebGL correctly, not all do, and not all distro/desktop/browser combinations work.
The fact that OpenGL errors appear above doesnt surprise me; afik the appimage bundles a web browser. Probably a really elderly one.

1 Like

Thank you both for letting me know I am looking for laserweb vs laswercut :slight_smile: I’ll take a look at the laserweb page and try to get that working on my localhost and report back :slight_smile:

Again thank you both for the help!

So interesting enough, I tried running the appimage on 2 other linux machines with the same distribution and it worked fine. I am going to see if I can figure out what is different between the machines drivers/openGL installations. (It’s funn because all 3 machiens are running the same distro, so it must be something unique for what gets installed for the one machines video card) If I figure it out, I’ll post back the results for anyone else that has this issue.

1 Like

Thankyou for following up! I’m glad you have managed to get some progress.

Cool, I’ve updated the comment stating it’s platform neutral on both backend and frontend. I likely confused LaserWeb with LaserGRBL.

1 Like

It seems to run ok in the web browser but I still was not able to run it on the one machine as an appimage. My best guess is the driver for the video card in linux does not support it.

Thanks for the help!