Problem with laser power control

LaserWeb information

On the About page, I see that I have:

  • Frontend version: _4.0.999
  • Backend version:4.0.138

My settings are:
Generic GRBL
GCODE start G21 G90 M4 S0

Problem description

When I set the laser power of a cut or engrave to (for example) 50% , I expect GCODE file generated to set the s code to S500 , but instead it sets it to S0.5 i.e. 0.5%

I have used the same input svg file (a simple square) in lightburn to create GCODE and that correctly outputs S500

System description

  • My machine is a diode laser Atomsack K20

Have I missed a setting I should have changed ?

Thanks for your Help

1 Like

Hi Alan, welcome aboard etc… :slight_smile:

I think you are looking for the option PWM MAX S VALUE which is to be found in the Settings tab, under Gcode.

This defines the maximum (100%) value of S.

(I’d post one of my usual helpful screenshots but I’m on the road… sorry!)

hanks Owen , that sorted it out - sorry for bothering you but it was the first time I had set up a Laser engraver.

Alan Henley