Ok, so this is whats now consistently happening after 13 mm.  It is only

Ok, so this is whats now consistently happening after 13 mm. It is only shifting in the y-direction. I greased what needed to be greased and tightened everything down. I have put a fan on the y-stepper motor. Ive even tried changing the temperature of the bed. Still not sure what to do now…
Any advice would be great thanks :slight_smile:

Check the vref on your driver. Its more likely your over powering your stepper or the drivers are getting too hot.

Try slowing print speed to see if that helps… And also check your voltages on the steppers

Delta or Cartesian? Belt friction? Y friction? Delta arm blues? Crappy under spec motor? Loose motor wiring?

Check the temperature of the stepper drivers. My went up to 80 deg C before I added little aluminum coolers. At the same time I reduced the acceleration. I can not say which of both actions (may be both) helped to stopped the issue.

Probably a loose grub screw on the pulley gear. If not that, recheck belt tension and stepper motor current. But it probably is a loose or missing grub screw.

We had something similar happen to one of our machines. It was a dodgy stepper motor witch couldn’t keep up with the number of steps being thrown at it in the travel moves. When you slow down the print also slow down the travel speed and see if the problem goes away.

Your slicer probably thinks your print area stops there… check your printer config.

Motor current is too high.

are you printing ABS? if so, check you Y-blet clamp, if that printed in PLA, then the bed heat could cause the clamp to loose.

Tune your stepper driver/ polulu by adjusting the knob of z axis

Why the z-axis?

I had the same problem and these are the list of things that I found that can cause the problem:

  1. Belt is loose and it skips teeth
  2. Pulley is not completedly attached to the shaft of the motor because the screw is loose
  3. Motor current its too low and motor skips steps because it has not enough torque. You can also try to lower the printing speed to avoid this.
  4. Motor current is too high, driver heats up and disconects intermitendly.

Sorry about my English, I hope it helps. In my case it was number 2. =)

Im doing all the above just in case, thank you

Also, something that may help you: if the problem is driver overheating because there is too much current through it (and the motor), you can recognize this problem by a characteristic sound the printer makes. Its a kind of ticking sound that the printer makes intermittently, when the drivers and motors shuts down for cooling. If this is your case you can recognize the problem by this sound, this time or the next.

Just a thought… check and make sure the cables are not running past anything that would cause interference, such as a smartphone.

maybe try switching your stepper drivers, x and y.

@Stephan_Kyriakopoulo If all the other suggestions fail, as Stephan said switch the drivers (or the wires), if the problem follows the driver you will know which driver it is. If the problem says then you are dealing with a bad motor.