Mill cutting a Zaxis does not appear in Control

I am using LaserWeb/CncWeb 4.0.999 on my Windows 11 and although it works very well with laser cutting I cannot get it to successfully do mill cutting. I set up a project as outlined in LaserWeb4 - Milling Operations - LaserWeb / CNCWeb but the Zaxis controls do not show up in Control. I have the X & Yaxis controls show up but no Zaxis. Please tell me what I have forgotten to do or have done incorrectly.

Can you tell us about your CNC machine? Make, model, firmware type/version and if you’ve controlled the Z axis with some other means(machine LCD controls, UGS or other gcode sender, etc)?

LaserWeb docs had you setup your firmware here: Initial Configuration - LaserWeb / CNCWeb

The machine is a 3018 grbl and I can successfully Zaxis with Universal Gcode Sender. However if I run a version of LaserWeb on my Linux desktop Zaxis shows up fine and works.

1 Like

BTW Doug this is not a hardware issue but software, either Windows or Laserweb on Windows.

Since it wasn’t mentioned in your description and functioning hardware is required for software to work I had to ask. Thank you for answering the question.

With a functional Linux installation of LaserWeb, is there a configuration setup you can export and migrate to your Windows system? Like saving the Machine Profile from the Linux installation and installing it into the Windows installation: Machine Profiles - LaserWeb / CNCWeb

Maybe also try a different browser to see if that’s messing the Z axis display up.

Thank you Dougl

1 Like

Sorry I didnt chip in earlier, thanks @dougl for taking this on :wink:

In the Settings tab (left side of the UI) select Machine Settings and look for the option Z STAGE SUPPORT, enabling that should now cause all the Z axis options to appear in job settings.

As Doug mentions, you can export LaserWeb’s settings (as a nice portable .json file) from the Tools section of the Settings tab. If you have a ‘good’ setup in Linux it makes sense to export that, then import it into the App to bring the two into sync.


Thank you Owen.

@Alf_Stockton have you found a solution yet and if so, can you mark the which helped as “Solution” so others might find it in the future?