LPS Failed again

Last night I was happily cutting acrylic and 3mm ply when I needed to do a quick design change, made it available to my K40 and pressed send only to notice that there was no beam and on closer inspection, there was no beam coming from the tube. Furthermore, although my digital voltmeter was still registering tube voltage there was no movement from the ammeter, so having tried powering down and up a few times without success, I concluded the worst – LPS or tube or both gone bad!! So, I did a search on the site and came up with a post “This is my first post on here and I am hoping to get some” from Josh_Hutch in Dec 2017 which looks identical to my problem. In this post it was concluded to be the LPS not the tube. Bearing in mind I only changed out the LPS and tube together to Cloudray in July last year, this is extremely disappointing. Reflecting back, I have done a lot of cutting in that time of maybe 100 to 150, 300x200mm 3.5mm ply and mdf boards but all have been cut inside the laser spec (15mA which is 3.6v in my case and not higher that 20C using my DIY chiller). In July last year, when I had the original problem, we tried the LPS first, and this did not fix the problem so we changed out the tube which did but I kept the new LPS on the machine and held the stock LPS as a spare, but I never knew if this had also failed. I have now changed it for the spare and bingo it works so it is the LPS and I have confirmed this with some cutting today. The only other thing I can add to this sorry saga is the following. Around 2 weeks ago I noted an inability to fully cut the ply and checked all the usual suspects. In the end, I found this to be a cracked lens which was purchased along with new mirrors when I upgraded my full head set to a Cloudray CO2 laser head set in November. I had also noted a quiet buzzing noise which I took to being part of the above problem. When I replaced the lens a few days ago and I was back in business but I noticed the buzz was still there at times so perhaps in hindsight this was the LPS on its way out. The questions I have are as follows:

  1. I presume you agree that the LPS has gone bad. With such a short life of 6 months, I have asked Cloudray through Amazon for a replacement or a deal but I am not hopeful.
  2. Looking inside the LPS I can see nothing that shows what part might have failed. I presume there is no obvious repair that can be tried?
  3. I bought both LPS and tube through Amazon and I have noted they have a 50W variant versus the 40W part I purchased last time. Would it be better to purchase the uprated version to maybe provide greater reliability?
  4. Once replaced I will hold my stock LPS in reserve as I now know it works and it will help in any future diagnosis.
  5. Although I appreciate both LPS and tube are consumables, is there anything more I can do to help prolong life of both LPS and tube bearing in mind that I do a lot of cutting.
  6. Any ideas why my lens might have cracked?

If this is the console power knob, it’s only displaying what voltage is being applied to the IN terminal of the lps. The mA meter is a better judge of what the tube is doing.

This kind of stuff happens with almost all equipment in this price range… even in industry, but not as frequent.

The LPS is not really user serviceable (fixable). If you’re a technician and know electronics, it probably can be fixed if it’s a simple component. Many of these fail because the hv transformer or some other component we can’t get shorts or fails. Doubt you can even buy a replacement for it’s flyback transformer.

The 2nd point about an lps is that it has some very high voltages within the case… Unlike 120 or 240v working voltages, when you get over a kV it starts to reach out and touch you. Never heard of anyone dying from these, I’ve been bit by similar voltages and it’s not a nice experience. So I suggest if you haven’t worked on hv equipment to just replace the lps… in the long run probably a better solution.

DC excited glass tube lasers power output is relative to it’s length. Really between the mirrors, where amplification occurs.

A 50W tube is about a meter in length. The tube that came with my OMTech 50W China Blue was only 880mm and produced just a bit over 40W. Many of these machines have < 700mm length tubes making them more of a 30W tube. Even my China Blue didn’t have the width to hold a 50W tube. A good tube should last close to 10k hours.

I’ve used this as a guideline for many years now and find it pretty reasonable.

Pretty much the only thing that hurts lenses is mechanical stress. If it isn’t seated properly it will be stressed. The most likely cause is the lens is dirty and heats up from the laser, creating mechanical stress and causing the lens to crack…

When a beam goes through a lens or reflects off a mirror, there is a loss of energy, this commonly translates to heat. It’s possible that just using it caused the failure.

When a tube failure occurs, the lps produces very high voltages as there is no and never will be a load until it arcs to the chassis. This excessive voltage has taken out many lps…

As you can see, even at low pwm rates, tube life is reduced, if you run these at over 70% power, they have a much shorter tube life.

It also advises the length of the tube at 25", which is 635mm, shorter than that of a 30W (700mm) tube indicating it’s < 30W also implies that 15mA may be excessive.

Since it’s lasing at 100% anytime it lases, this has an effect on tube life …

Good luck


1 Like

Thanks for your comments. I thought the LPS would not be fixable but I thought I would ask the question anyway. Just to be clear I was talking about a 50W LPS not tube but I have now noted the 50W LPS does not have the same connectivity or footprint and the 40W so is not an option. My tube is 700mm with a rated power of 35 Watts and I am operating at a maximum of 15mA so are you saying this represents 100% power? I can do 2 passes at 10mA and 10mm/s for 3.5mm ply but the advise has been that 1 pass is better than 2 where you can. I note your comments about keeping the lens clean to reduce mechanical stress. I appreciate the LPS can be taken out by a tube going bad but I am pleased this has not been the case so I can continue until I get a replacement and then hope to have a working spare.

Brilliant news. Amazon are refunding the whole amount. I have just ordered a new LPS.

1 Like

That’s the maximum operating current limit… every time it lases, it lases at the manual set current value.

Great news the are taking responsibility… and doing something…

Let us know :wink:


There is good news and bad news. I received the new LPS from Amazon today (overnight service) and I will be able to return my old one back tomorrow for a full refund. As it turns out it is £5 cheaper this time round. The bad news is that although it does look brand new, when I plug it in, it does not lase but when I press the button on the LPS it does. It also buzzes like the old one when I press the button. I did note, if it is relevant, that it takes just 1.8V for 15mA. Just to make sure I am not going mad I put the stock spare back in and no problem with either the button on the LPS or on the console and there is no buzzing. It is also interesting that again the spare needs just 1.8V for 15mA which is what I recollect when I changed it out in July. Remember it has always been 3.6v for 15mA for this one. It does seem strange that I seem to have 2 units exhibiting the same behaviour whereas my stock item does not. Can I conclude from this that Amazon have sent me a dud or is there anything else I should check out first?

Problem solved. Why would it work by pressing the button on the LPS and yet not when you press the test button? The answer is that the cabinet switch is open circuit. So why did it work when I changed back to the spare twice and it worked both times? Because it was intermittent and so masked the problem.

I do have two final questions which hopefully can be cleared up. Both the spare and the new LPS provide the maximum of 15mA at around 1.8 – 2.0V whereas the one I have replaced is 3.6V. Why is there such a discrepancy and does this say anything about the LPS as both the new and replacement LPS are the same model? I would have thought the voltage would be consistent for a given tube.

When we talk about “maximum power”, I had assumed that on the previous LPS 3.6v versus a maximum of 5V represented 72% of “maximum power” (assuming a linear scale) and in the case of the new LPS, this is 36% of “maximum power”. So, in this case is my “maximum power” at 15mA 100% or 36%? I understand that over time as the tube wears, the voltage to provide 15mA may increase but this is not the case yet. Whatever the answer I don’t intend to use more than 15mA.

Check out this thread … it’s a bit long, with a Monport.

If you have questions, sing out…


In effect it’s lasing at 100% power any time it lases.
Power isn’t actual power, but power/time, just like a ssl…
One of the reasons I attribute to their relatively short tube life.

Not sure I fully understand the whole post but I think this is the relevant paragraph. If I am cutting then wouldn’t I want to lase at 100% power anyhow with the highest speed.
When I ran some tests I noted the quality clean cut on both 3.5mm ply and 4mm acrylic with minimal flashover and further it is cutting fully through 3.5mm ply as low as 6mA at 10mm/s which seems exceptional. Clearly good news but I cannot explain this enhanced performance versus the power required by the previous LPS.

Solid state lasers are only on or off. You cannot lase a ssl at 50% power. The controls for this are commonly a ttl level pwm signal. Although this is a digital signal, the lps will accept a dc 0 to 5V analog signal.

A 50% power setting in your software should generate a 50% pwm signal from your control board. This turns the laser on for half the pwm period and off for the other half. This gives 50% power, it’s actually 100% power 50% of the time.

Conversely, a glass tube dc excited laser can lase at a 50% power level.

An led turns off/on at 50% rate for 50% power/time and a co2 is on 100% of the time at 50% power.

The K40 setup has the power level set by the manual pot and the pwm enabling the laser. Anytime it lases, it will lase at whatever the manual value is set. In effect, running the tube like an led laser.

Make sense?

Most of these K40 types do this and most of us are aware of what’s happening during the pwm cycle.

Keep in mind that the period is usually 0.1ms or 1kHz, sometimes called the base frequency. This is pretty fast, not electronically but compared to it mechanically and how people related to time.



Yes it does. Thanks.