Looking at the video does anyone know why there is a stutter/chattering noise moving

Looking at the video does anyone know why there is a stutter/chattering noise moving my Z right before it prints? I think it’s causing it to skip steps. It has crashed my nozzle into the glass several times right after I had the bed perfectly level and nozzle spaced with a business card for spacing.

I can move my Z up and down manually in repetier host and it always returns to the same spot.

Here are some details of my setup that might help:

Marlin firmware. Z is 8mm fine rod. Z is pulley reduced (20 tooth on motor 36 tooth on the rod). I have 1/8 microstep enabled on Z. I am using slic3r through repetier host.

Thanks for any help.

Your rapids on your z are too high. When you start the program it rapids to z0 and alot of times the rapids are just too fast. I always home my z manually before I hit go. Otherwise I have the same issues.

Found a quick Fix. Removed:
G1 Z5 F5000 ; lift nozzle
from Slic3r g-code setting.


@Joe_Spanier thanks for the tip

f5000 is the speed. You could decrease is to something more reasonable.

Yea I think mine is around 1000

If you set your max-feedrate on the Z axis down a bit in your firmware, you can ensure with 100% certainty that your Z axis will never go faster than that speed (so that any slicer changes in the future don’t cause these issues.)

My z speed is set to 50 I believe. Fast enough for my prusa…

Thanks to everyone for the input. I could never have made my printer happen without all the inspiration from everyone here in the 3dprinting community, and all the support from the cumulative knowledge of the group.

So that’s why some of my prints won’t stick to the bed! I think I also have Y acceleration set too high, because my prints sometimes jump a few millimetres in Y in the middle of fast infill patterns. What acceleration would be reasonable to achieve on a Prusa Mendel?

@Hannes_Lilliefeldt I have mine with 8000 in both X and Y axis, but my solution to that was putting a limit (15 Hz in my case) on the “maximum frequency” which is the number of times per second that it changes directions on x/y axis in small zig-zags. It slows down the movement on that kind of places and it removes that kind of step skipping. Setting is on Marlin, on “Configuration_adv.h”, and it’s named “#define XY_FREQUENCY_LIMIT 15”

Reduce acceleration and speed by half or more. Leave 2.5mm/s2 for acceleration, and 5mm/s max speed.

your printing bed is quit heavy in relation to the motor.

@Ronald_Burggraaf I know but there is so much mechanical advantage with the pulley reduction I think its ok. There is 5760 steps per the reprap calculator using 1/16 micro steps.