LaserWeb on Linux, Sculpfun, Grbl controller, no output

I am new to all this, so forgive me if I have missed something obvious.

I am experimenting with LaserWeb on Linux, and a Sculpfun S9, which has grbl 1.1h firmware.

I had a lot of difficulty getting the laser to turn on.

I downloaded the latest appimage I could find, v4.0.994-130 and could get the laser to move OK, but no output, also nothing on the test button.

To get the laser to turn on I had to add M3 to the Tool_on field in Settings>Gcode>Tool_on.

To get the Laser test button to work I had to increase the Tool_test_power in Settings>Gcode above 0%

Is this just an issue with my engraver, or do these settings need to be added to the default setup?

Thanks for all your work, I have only played for a couple of hours, but LaserWeb looks like what I need.

The default tool-test power is deliberate, This can be a dangerous option and we want people to enable it by choosing the default power.

For GRBL you do not need to use the TOOL ON/OFF macros at all, they should be empty.

Make sure you have laser mode enabled in GRBL ($32=1)

Your startup code should have M4 S0 at the end; this will enable the laser and set it to dynamic mode. It will then only turn on while in motion.


Thanks for the reply.

Laser mode was enabled.

I have added the M4 code to the startup, and removed the M3, works and appears to have made the movement less jerky.

I assume this would be an issue with any android grbl based system, maybe the M4 startup code needs to be added to the appimage file, so LaserWeb works “out of the box”.


1 Like

Thank you for the feedback :slight_smile: Glad you got that working.

The current LW release doesnt have a specific grbl profile, hopefully this will be corrected in the future.