Laptop not recognising K40

Hi all

I had to replace the M2 Nano board with a Nano M3 board. I switched a couple of y axis wires around and the laser head now resets to top left as it should however, the laptop has never recognised that the laser is connected. It does not make the ‘usb detected’ noise when connected, I cannot see it in the systems connected devices list nor can K40 whisperer or Lightburn detect anything connected.

Any suggestions?

Many thanks

Mike

If you have another computer I would try connecting different computer to see it that works. (The idea is to figure out if it is a computer problem or controller problem)

I have a couple of questions that your initial post raised:

  1. Why did you need to change boards M2 to M3? Did the M2 stop connecting to the computer?

  2. I would not expect that swapping stepper motor wires would be needed when changing from M2 nano to M3 nano. Did you change something else that you didn’t mention that required you to switch the wires?

Scorch

1 Like

Thanks for the reply Scorch!

I have tried another laptop, same issue. The original laptop will recognise other USB devices also.
The K40 stopped working and I traced it to the M2 board, I could not get another M2 so opted for the M3 as I was advised by the seller it would be a straight swap (:man_shrugging:). When installed, the laser head was trying to reset to the bottom left so I swapped 2 of the servo wires to change the polarity and it reset top left as normal.

Thanks again

Thanks for the additional details. It sounds like the controller is getting power (since it is homing) so lack of power is certainly not the problem. The problem seems to persist even when using a different computer so that indicates it is probably not a problem on the computer side.

You could try connecting to your old M2 board. You said “The K40 stopped working and I traced it to the M2 board” but you never indicated that that board had the same problem or a different problem. If it had the same/similar problem there may be something else going on. Could be as simple as your USB cable has gone bad. Definitely try a different cable or wiggle the existing cable to se if you can get the controller to connect to the computer. (i.e. make the ‘usb detected’ noise)

1 Like

Thanks again Scorch

Yes, I tried another cable but again the same issue. From memory, I think the M2 board was still recognised by the laptop but would not control the servos at all. I will try the old board with servos disconnected just to make sure.
Not sure if it should make any difference but this K40 is the ‘ribbon’ type as below. Agreed on the power side, it should be connecting! I will report back once I’ve tried the M2.

Looks like your Y-axis stepper motor is plugged into the X-axis socket. The ribbon cable also goes to the X-axis motor. So right now you have the same stepper driver hooked up to both stepper motors. I don’t think that would break your controller board (but I have never tried). That would explain why you thought you needed to do some wire swapping. You should put the wires back the way they were and plug the Y-axis stepper into the Y-axis port.

This will not solve your problem but it will be a step in the right direction.

2 Likes

Thanks Scorch

In my defence, I went ‘like for like’ with the plugs (pic below is original m2 from stock delivery)

I finally got a response from the supplier, would a dongle key rectify an issue like this? As I said before, we never had one before.

“we can confirm all of the M2/M3 board must be working with the Dongle Key. You can confirm with K40 manufacturer or M2 manufacturer (http://www.3wcad.com/)

is it possible to change a computer for test?

recommend you to use Corellaser with dongle key for output, also need to input the borad ID then do output in software. then try with lightburn”

I tried the original M2 board and it was the same, not detected by the laptop. When plugged in (just the power plug) there is burning smell from the power supply, as if the M2 board has taken something out on the PS. I’m now thinking there may be an issue with the PS, maybe on the data transmission side? Not looked in to it fully but guessing there is some sort of ~5v can bus type communication on the centre 2 wires of the plug?

Have you had the laser engraver successfully working in the past?

The problem with connecting the controller to the computer may just be that the driver that K40 Whisperer needs is not installed on the computer. (it is possible that a windows update removed/affected it)

What error are you getting when you try to connect?

Using the dongle with the the Chinese software (Laser Draw) might allow you to connect to the controller if the driver that K40 Whisperer uses is not installed on your computer.

I can’t find any reference to you saying you didn’t have a dongle in your previous posts. Do you have a dongle but never used it? Or did you never get a dongle in the first place?

You mentioned Lightburn earlier and the message from the supplier mentioned Lightburn. Just to be clear, Lightburn will not work with the M2/M3 nano board without having Meerk40t doing interpreting in between them.

Is this not the m3 board?

:smile_cat:

@jkwilborn that is not referring to a Lihuiyu M3 Nano. That is an Awesome Tech Mini Gerbil v3 (MG3). The “M3” reference in that post is misleading but it clearly states that they are referring to an Awesome Tech board.

1 Like

Thanks for the clarification… hard to keep track of this stuff… Didn’t know nano made their own.

:smile_cat:

Yes, bought the machine in 2020 and have been working it quite hard ever since. Did some minor upgrades (power control board, air assist, mirrors and lenses etc) and changed the tube a few times.
I have re-installed the drivers several times, there is no error, it is just not recognised by the laptop that a new USB device has been connected. We never used a USB dongle key from day 1, I remember seeing a USB stick originally but unsure where that went to be honest.
I downloaded a trial of lightburn just to see if it would ‘see’ the K40 as a device but it didn’t.
The laser will fire on the test push button, the steppers will move the head to it’s reset at top left but the controller will just not connect with laptop. I’m think I’ve managed to find a wiring schematic for the machine so going to do some testing and see if anything has been damaged.

Did some quick checks this morning, noticed the cooling fan doesn’t work anymore (usually kicks in on power up then tails off). The only thing I did notice, which may be normal, is that there is 24Vdc reading between the 24vdc and 5Vdc terminals as per drawing below, can anyone with a working K40 confirm/deny this?

Either way, I think I’m going to order a new power supply and a different controller board. Could anyone recommend a uk supplier and simple upgrade/replacement board? Long story short, this is my ex-wife’s machine that is part of the settlement and I need to get it working as cheaply as possible and out of my house! :joy:

Thanks again for all your help!
K40 PS

Is the led down on the LPS lit?
Is there 5V present on the LPS?

Hi Don

Yes, LED is lit.
Yes, 5Vdc to Gnd is present

@Mike_Wright
Mine does not measure 24V between the 24V and 5V outputs (It measures 19V as would be expected)

Gnd to 5V out measures ~5.05V
Gnd to 24V out measures ~24.05V

1 Like

SOLVED

Thanks Scorch, but I think you had fixed the problem a few posts ago!
Regarding the Y-Axis plugged in to the wrong socket, where I went like-for-like with the plugs from the original M2. I thought I would attend to this when I fixed the connection issue as I had the motors disconnected anyway. I was checking the machine earths this morning and I felt compelled to swap the 2 wires back over and plug in to the correct Y-axis plug. When I did and switched the machine on, it reset top left and I heard the most beautiful ‘USB connected’ sound from the laptop! I re-installed K40-whisperer along with the drivers and all good!

Hopefully this will help anyone else who comes up against the same issue in the future, thanks again for your support!

4 Likes

Just an update, after doing a couple of test prices (including a 10-15 minute engrave and cut), I dropped the machine off at my ex-wife’s house and ran another quick test piece before leaving it with her.
A couple of days later she text saying the machine has the same problem. On inspection it had indeed stopped again.

When switched on and everything connected, the power supply ‘ticks’ like a thermal overload is being operated every second. When I disconnect the board’s power plug, the power supply powers up and sounds fine. It’s as if the controller board has an earth fault maybe.