K40 with Taurino + RAMPS 1.4 - stops responding if laser fired

(Gabrijel Erman) #1

Hi,

I converted K40 to have Taurino with RAMPS 1.4 with Turnkey Tyranny firmware. I get it to work and I left the knob for maximum power, “Test” button and “Engrave” button connected so the RAMPS is connected with an 2n7002 to the “L” line on the PS. The problem I am facing is that Repetier software loses connection to the Taurino board but only if I fire the laser:( I generated the g-code and if I don’t enable the laser with “Engrave” button, the movements of Y and X axes are OK. If I enable the laser, Repetier looses connection (laser stops completely) and only what helps is disconnect and reconnect USB cable. The stop is not instant after the first laser beam but is after a random running time. I also did the following test:

  1. switched all OFF and then back ON
  2. connected USB cable to laptop
  3. connected Repetier and issued “home” command
  4. fired the laser with “Test” button a couple of times
  5. Connections was lost over USB but Repetier doesn’t show that (so K40 appears as connected). When I try to issue a command in Repetier, it just stacks commands. Clicking disconnect and connect in repetier doesn’t help. I have again to unplug and plug back USB cable.

As I don’t have an LCD connected to RAMPS (for now) to see if Taurino is blocked or only the USB connection, I don’t know what else might cause this behavior. Is it possible that HV from PS (as it is not covered) produces this problems with Taurino? Thanks.

(anon57870006) #2

Baud Rate same in firmware an Repitier?

(Don Kleinschnitz Jr.) #3

I have seen and troubleshot this kind of problem many times.
It is usually 1 or more of these things:

  • The LPS is bad and the HVT is arching.
    * Do you see any problem with the IN voltage vs the current output of the laser? I.E. laser current running low
    * Do you hear hissing sounds
    *Are you using distilled water as a coolant?
  • Poor grounding:
    * https://donsthings.blogspot.com/2018/09/battling-electrical-noise-in-cnc-builds.html
  • Poor quality USB cable
  • Certain USB boards are susceptible to noise (I do not know which ones)

I would put the cover back on the LPS and insure that there is good signal and frame grounds between the controller and the LPS.

Also try a fresh and good quality shielded USB cable.

1 Like
(Gabrijel Erman) #4

Baudrate is set to 115200 in firmware and in Repetier so that shouldn’t be a problem.

To be honest, I don’t know how exactly the laser firing shall sound but I hear two type of sound:

  1. like a wind blowing fast through a small tube (don’t know how else to explain)
  2. “popping” sound together with the first mentioned.
    first is more common than the second one. So, to ask here: what sound needs to be?

The ammeter show always set current and turning the know changes it. So this looks like working ok.

Yes, I use distilled water for cooling.

By grounding is the actual grounding to 220V or? I connected that from the 220V outlet to the “PG” on the LPS of the laser. Originally, there was no wire.

Regarding the cover of the LPS, I got mine without the cover:( So, as on picture in my previous post…

(Don Kleinschnitz Jr.) #5

First be warned that the LPS is LETHAL getting anywhere near it while it is on can KILL you!
You need a cover for noise and safety reasons.

LPS HVT arching sounds like a hissing or crackling noise
You might be able to see it around the HVT if you turn out the lights
It sounds to me like you do have a problem with the LPS.

Grounding is a complex subject especially ground loops.
Insure that the LPS chassis is screwed to the frame
That the FG connection on the LPS is connected to the frame (with screw)
That logic ground is connected to the frame (with a screw)
That all covers are connected to the frame ground
That the input ground is connected to frame ground

1 Like
(Gabrijel Erman) #6

Thanks for detailed explanation.

So this “wind like” sound is not good at all when laser fires? The “pop” sound can also be heard after the “Test” button is released. Shall I just check if there is any arch light from the PS in the dark or most certain I shall look for a new LPS? If the LPS is bad, the laser beam shall also be weak?
Looking at the grounding, FG of the LPS is connected to the chassis (checked with an ohm-meter) but GND from LPS that goes to the Taurino is not connected to chassis. SO, if I understand well, grounding from the 220V shall be connected to the chassis. Also GND and FG from LPS shall be connected to chassis?

(Don Kleinschnitz Jr.) #7

Ok to be clear:

LPS
FG pin of the left green connector to the frame
GND on the green or white connectors; do NOT connect to frame but it should still read 0 ohms to frame as it it grounded internally? It should however be directly connected to the controllers ground.

Machine
The safety ground on the input plug connected to frame

Its hard to tell if the laser power supply is bad. But a symptom is that the laser is weak and current is lower than normal for a given power setting.

(Claudio Prezzi) #8

Can you show a schematics of how you connected the MOSFET?

The gate sould be connected to the PWM out of the controler (via resistor), the source should be connected to GND of the controller and the LPS and the drain should be connected to the L line of the LPS. Like this:

(Don Kleinschnitz Jr.) #9

I did not pick up on the 2N7002 driver as @cprezzi did.

To be clear, cause I know @cprezzi knows this. The drain connects to the L pin on the LPS with nothing else connected to that drain. The mosfet should only supply a ground to L when PWM is in on state.

@morfeus Also would be useful to post picture of the physical 2n7002 wiring and location?

Most times I have seen Ramps implementations use an on board mosfet for the PWM connection to L? I think they used one of the heater or fan ports.

What manufacturer Ramps board do you have?

Where on the Ramps board did you connect the 2n7002.

(Gabrijel Erman) #10

Hi,

The mosfet is on a small PCB together with an 100kOhm resistor. All together is connected to D6 on RAMPS. The schematic is:

  1. Gate to D6 and one lead of 100kOhm resistor
  2. Source to GND and second lead of resistor
  3. Drain to “L” on LPS
    Place inside the laser and the actual board can be seen here (small PCB near RAMPS power connector with yellow, orange and blue wire):


    So I think that should be OK?

The fact that arduino stops to communicate when laser fired only with “Test” button is what concerns me the most because in that case Arduino is not communicating to LPS at all. However, I didn’t try to unplug the “L” pin from arduino and then fire with “Test” button and check what happens…
Regarding the set power vs. actual power on ammeter, I don’t know how to check that because the potentiometer can be fully rotated 10 times (it is not the standard one-almost 360 degree rotation. Don’t know why) but I can confirm the current rise when rotated right and decrees when rotating left. Also, I now tested total number of rotation and figured out that it was set to exactly half total turns (5) and when I was testing yesterday, the ammeter was rising to 8-9mA.

Anyway, is there any “normal” sound that shall be heard when laser fires? Or there shall be no sound at all?

(Don Kleinschnitz Jr.) #11
  • Why are you not driving the L pin directly from an open drain on the ramps?
  • I don’t know what D6’s output circuit’s looks like
  • Your gate pull-down of 100K seems high, try 10K
  • I can’t tell you what the normal sound is as I have lots of air noise when mine is running. I do know that noticeable crackling and hissing usually means a corona from a leaking HVT. You could try posting a video with the noise.
  • My guess is that this problem manifests itself only when pushing the test because in that case the laser is full-on not pulsing. I imagine that you will have intermittent problems with high power jobs.
  • Sounds like you have a 10 turn pot, 9ma sounds about right for it set to 1/2 its turns.
  • What happens if you turn the pot all the way up and test fire, does it go to full power (20 ma) any different noise. Bad LPS will often not output full power due to arcing.

Still sounds to me like the LPS is injecting noise into the controllers grounding system.

My advice:
With these kinds of noise problems I have found that you have to try stuff to see if you can narrow in on the source and the method the noise is affecting the controller.

  • Disconnect the LPS end of the blue L wire and test fire. If it still kills the USB then there is a radiated problem. If not, it is likely conducted and somehow coupling through the L wire into the controllers ground.
  • Totally disconnect the external driver from the system and try a test fire.
  • Shield the LPS (cover).
  • Use an onboard open drain vs the eternal driver.
  • Shorten the wires to the external driver board and verify good short grounds
  • Try a different and shorter USB cable (that blue usb cable looks like the stock one and they are known to have problems).
  • Try tying the controllers ground to the frame directly.
(Gabrijel Erman) #12

Hi,

D6 is ramps “servo” output on the schematic a few posts earlier. So it is just direct arduino output. I have tried to ground the controller board but the problem is still here. Also, disconnecting blue and firing some test laser shoots, results in USB communication problems.
When testing today, I did some videos where one can hear squealing like this (on the beginning is head movement but just before the end laser fires and you can hear this noise):
(I was unable to upload the file here so please, check on dropbox) https://www.dropbox.com/s/jihw5h8ld7304xw/VID_20190319_174257.mp4?dl=0
also on this video (at the end the laser stays on and high pitch sound can be heard):
https://discourseuploadspace.sfo2.digitaloceanspaces.com/original/3X/5/c/5ce8301dfaf29dbda847e401bab4da16dcd00b1b.mp4
I also tried test fires and the same sound can be heard with additional “popping sound” even after button is released.
I also tested full power and the ammeter reached some over 20mA so I think that’s ok. As I tested only short shoot, I didn’t pay attention if squealing or popping can be heard.

Based on all described, shall I purchase a new LPS or?

(Don Kleinschnitz Jr.) #13

I cannot with confidence say to buy a new supply. Usually bad supplies will not put out full power. That is not to say that there still is not a HV leak somewhere.

I did not hear much on the video other than the steppers seemed noisy.

As I understand when you disconnected the L connection from the controller and test fired the controller disconnected. This makes me think the noise is radiated or a ground loop.

Did you try the other suggestions?

Another suggestion is to ground the PC to the frame of the laser machine.