K40 Whisperer load svg from Illustrator

Hey there,

I’ve been trying to load a svg which was exported from Illustrator earlier.
The svg does look fine, but whenever I try to open it with K40 Whisperer everything that was grayscale just turns black (yep, I have enabled halftone in raster settings).

I’ve tried it with multiple svg’s now and some of them work while some just don’t…
One of the not working graphics is attached.
Policy%20Liberal

There is some formatting in that file that K40 Whisperer does not understand. (I will take a look at fixing this in K40 Whisperer in the future. I was not previously aware of this problem.)

A work around to get a file like that to work in the mean time is to:

  1. Open the SVG file in Inkscape
  2. Select everything (Ctrl-a)
  3. Ungroup everything (Ctrl-Shift-g, multiple times)
  4. Save the SVG file

After doing this procedure it should open correctly in K40 Whisperer.

A side note: Your red line will not show up as vector cut because the red line is colored red using the fill color. Fill colors do not produce vector engrave or vector cut features. To make a vector engrave or vector cut feature the color needs to be set to red or blue using the stroke (Stroke_Paint) color.

Scorch

4 Likes

Thank you for your response Scorch!
Your workaround fixed the problem.
I might use a little script there since I have dozens of these svg cards :slight_smile:

As for your side note: For the red line I used “align stroke to inside” to not have any lines out of bounds.
Seems like Illustrator is not exporting it as a stroke at all, whereas the blue line had “align stroke to center” which worked fine.

Thank you for your awesome job on K40 Whisperer!

1 Like

This issue has been fixed in K40 Whisperer Version 0.40, which is now available on the K40 Whisperer web page. Thanks for letting me know about it.

Scorch

2 Likes

You will also have this problem if your Document Color Mode in Illustrator is set to CMYK. Most of my Illustrator work is in CMYK so when I started trying to make SVG files for laser cutting I couldn’t figure out why they were going grayscale. Turns out that even if you manually selected 255,0,0 or 0,0,255 for the red/blue lines when Illustrator was in in CMYK mode it auto-converted those pure RGB colors to CMYK when saving as SVG so they were no longer pure. You can see this by opening the saved SVG file in Illustrator and looking at the RGB value of the lines. Changing the color mode to RGB fixed the problem and they work perfectly every time now.

Another quirk with Illustrator is that if your units for text size is in points you’ll need to convert all text to outlines before saving the SVG or K40 Whisperer will give you a units error.

Rusty, can you create (and send me) a SVG in CYMK mode with the features with colors set to red and blue so I can see how far off they end up being. K40 Whisperer allows for some variation in the colors I might increase the tolerance if it makes sense.

Example files with the text variations you described would be interesting also.

Thanks,
Scorch

1 Like

Thanks scorch, the new version works like a charm!
But there’s still 2 more problems I’m facing with Illustrator’s SVG files:

  1. The following test file turned black upon importing in K40 whisperer 0.39 (even the ungrouping workaround you mentioned before did not fix this). In version 0.40 it just throws “list index out of range”.
    Color Template

  2. I used this script to create a single line font in Illustrator for vector engraving (blue) and exported it as SVG.
    Version 0.39 - again shows a black background while 0.40 throws “list index out of range”.
    Text

Edit: I’ve just doublechecked it and it seems like this has nothing to do with my monoline text, but with the red and blue stroked borders around it (for both SVG files)