Just having re-furbed my old dust collecting Zenbot to GRBL and discovering Chilipeppr :D

Just having re-furbed my old dust collecting Zenbot to GRBL and discovering Chilipeppr :smiley: I’ve started playing around with PCB routing and the auto levelling within cp.

However I’m having issues with very first point on auto level using GRBL Workspace. My auto probing etc is definitely working, but as you can see below this is 100% typical with every probe run.

I’ve tried moving the workspace around the material, even different materials and always the first probe is out compared to the rest of the surface.

I would be grateful if anyone could shed some light on what I might be doing wrong? I’m using the default settings, example below Ive played with manual spacings.


I only know probing on TinyG, so I’m not much help on Grbl probing issues. That image does look completely wrong though.

here is a short vid I took of it, and you can see same issue https://www.youtube.com/watch?v=l6xi1BKST9A

Thanks @jlauer I do have a tinyG2 shield thats just arrived that was intended for this project (but didn’t arrive in time) and might see how that goes once I pick it up from the post office

I haven’t had the time to play around with tinyg2 on Due + Gshield as yet, so sticking to GRBL for the time being until I can devote some time to it as its working for everything else atm.

In the interim can anyone using GRBL on default GRBL workspace confirm that the probing works as intended? Its pretty well working for me except for the very first probe. I have tried the latest chilipeppr local server on a PC (I run Mac so am using the older version binaries) and had the same issue

I know my probe is working as I use it for Tool height zeroing and stock edge detection with no problems, however I think I’ll add a cap tonight to see if it makes a difference.

Tonight I’ve added a cap across the probe just to make sure its not noise causing (which I doubt as is only ever on first probe point and same results). I’m starting to suspect is a version conflict with GRBL and GRBL workspace? I am using latest version of GRBL from github-0.9j is this the version I should be using with CP workspace?

I hear a lot of people using version i, not j, so maybe that’s the issue.

@John thanks will try tonight when I get home, in the mean time I’ve just familiarising myself with C9 and the widget code and will see if I can troubleshoot from there as well…all new to me :slight_smile: