i need help :( i am using ipixel led's ws2812b(ws2811),

gplus
(Jenelle Tuting) #1

i need help :frowning: i am using ipixel led’s ws2812b(ws2811), tried to test 1 strip of 25 leds then setting it up to a 5v supply, then data pin is connected to an arduino uno, the arduino uno is connected to usb/then tried to power it with adapter also. then ground of led connected on the arduino’s ground pin. but nothing happens. i uploaded a simple code, one red display on the 1st led, to be able to see if the led is working. but nothing happens. furthermore when supplied through usb, when i disconnect the data pin to arduino and connect it again the strip will light up once then it shuts off. it displays red color in the 1st led though, but it displays other color on the other set of leds. i also tried hooking it up in different supply. but same thing happens, when i connect negative and postive it will light up once then turns off.

(Andrew Tuline) #2

Some thoughts/suggestions:

http://www.tuline.com/dru/content/my-fastled-faq

(Jon Burroughs) #3

Share the code you’re trying to run on the Uno, there might be an issue there…

(Jenelle Tuting) #4

@Jon_Burroughs thankyou the leds are now working, i found out that the arrow is opposite, thats why it wont work.